Commit 3d51f2f9 authored by Oliver Hader's avatar Oliver Hader Committed by Benni Mack
Browse files

[BUGFIX] Use proper version range in Git hook

Resolves: #91471
Releases: master, 10.4, 9.5
Change-Id: Ib008a46cc2edb368fed3fc937858f1f3870938b5
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/64542


Tested-by: Benni Mack's avatarBenni Mack <benni@typo3.org>
Reviewed-by: Benni Mack's avatarBenni Mack <benni@typo3.org>
parent f238fde4
......@@ -222,7 +222,7 @@ checkForResolves() {
# Check for existence of a "Releases: " line.
#
checkForReleases() {
if ! egrep -q '^Releases: (master|[0-9]\.[0-9])(, *(master|[0-9]\.[0-9]))*$' "$MSG"; then
if ! egrep -q '^Releases: (master|[0-9]+\.[0-9])(, *(master|[0-9]+\.[0-9]))*$' "$MSG"; then
COMMIT_MSG_ERROR_FOUND=1
ERROR_TEXT="${ERROR_TEXT} - You need a 'Releases:' line. For instance: Releases: master, 8.7\n"
fi
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment