Commit 09e17082 authored by Christian Kuhn's avatar Christian Kuhn Committed by Benni Mack
Browse files

[TASK] Raise typo3fluid/fluid:^2.7.2

Raising from 2.7.1 brings:
* A couple of bug fixes, especially ternary should
  work much better when cached
* Basic PHP 8.2 support
* A couple of minor additions and more relaxed
  handling. Some of these will materialize in v12
  with upcoming patches

> composer req typo3fluid/fluid:^2.7.2
> composer req typo3fluid/fluid:^2.7.2 -d typo3/sysext/fluid --no-update
> composer req typo3fluid/fluid:^2.7.2 -d typo3/sysext/adminpanel --no-update
> composer req typo3fluid/fluid:^2.7.2 -d typo3/sysext/redirects --no-update
> composer req typo3fluid/fluid:^2.7.2 -d typo3/sysext/core --no-update

Resolves: #98048
Releases: main, 11.5
Change-Id: Ibc94b02823913347465245201442277f048c5c0b
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/75325

Tested-by: core-ci's avatarcore-ci <typo3@b13.com>
Tested-by: Stefan Bürk's avatarStefan Bürk <stefan@buerk.tech>
Tested-by: Benni Mack's avatarBenni Mack <benni@typo3.org>
Reviewed-by: Stefan Bürk's avatarStefan Bürk <stefan@buerk.tech>
Reviewed-by: Oliver Klee's avatarOliver Klee <typo3-coding@oliverklee.de>
Reviewed-by: Benni Mack's avatarBenni Mack <benni@typo3.org>
parent 9ee71ce2
......@@ -4,7 +4,7 @@
"Read more about it at https://getcomposer.org/doc/01-basic-usage.md#installing-dependencies",
"This file is @generated automatically"
],
"content-hash": "67dc02f10581f57dd92bc8042e61886a",
"content-hash": "6688d72e425e4b53a103a046c1f751b2",
"packages": [
{
"name": "bacon/bacon-qr-code",
......@@ -4284,26 +4284,30 @@
},
{
"name": "typo3fluid/fluid",
"version": "2.7.1",
"version": "2.7.2",
"source": {
"type": "git",
"url": "https://github.com/TYPO3/Fluid.git",
"reference": "a60a9219ab556104c70abb3efad45caa2c188aa5"
"reference": "50ee1ee19ee00947c92bcb554bbea4fb5463b468"
},
"dist": {
"type": "zip",
"url": "https://api.github.com/repos/TYPO3/Fluid/zipball/a60a9219ab556104c70abb3efad45caa2c188aa5",
"reference": "a60a9219ab556104c70abb3efad45caa2c188aa5",
"url": "https://api.github.com/repos/TYPO3/Fluid/zipball/50ee1ee19ee00947c92bcb554bbea4fb5463b468",
"reference": "50ee1ee19ee00947c92bcb554bbea4fb5463b468",
"shasum": ""
},
"require": {
"php": ">=5.5.0"
"php": "^7.2 || ^8.0"
},
"require-dev": {
"mikey179/vfsstream": "^1.6",
"php-coveralls/php-coveralls": "^2.1",
"phpunit/phpunit": "^8.1",
"squizlabs/php_codesniffer": "^2.7"
"ext-mbstring": "*",
"friendsofphp/php-cs-fixer": "^3.4",
"phpstan/phpstan": "^1.7",
"phpstan/phpstan-phpunit": "^1.1",
"phpunit/phpunit": "^8.5.26 || ^9.5"
},
"suggest": {
"ext-json": "PHP JSON is needed when using JSONVariableProvider: A relatively rare use case"
},
"bin": [
"bin/fluid"
......@@ -4319,11 +4323,13 @@
"LGPL-3.0-or-later"
],
"description": "The TYPO3 Fluid template rendering engine",
"homepage": "https://github.com/TYPO3/Fluid",
"support": {
"docs": "https://docs.typo3.org/other/typo3fluid/fluid/main/en-us/",
"issues": "https://github.com/TYPO3/Fluid/issues",
"source": "https://github.com/TYPO3/Fluid/tree/2.7.1"
"source": "https://github.com/TYPO3/Fluid"
},
"time": "2021-11-12T10:06:45+00:00"
"time": "2022-07-28T11:24:11+00:00"
},
{
"name": "webmozart/assert",
......
......@@ -27,7 +27,7 @@
"typo3/cms-core": "12.0.*@dev",
"typo3/cms-fluid": "12.0.*@dev",
"typo3/cms-frontend": "12.0.*@dev",
"typo3fluid/fluid": "^2.7.1"
"typo3fluid/fluid": "^2.7.2"
},
"conflict": {
"typo3/cms": "*"
......
......@@ -70,7 +70,7 @@
"typo3/cms-composer-installers": "^2.0 || ^3.0 || ^4.0",
"typo3/html-sanitizer": "^2.0.14",
"typo3/symfony-psr-event-dispatcher-adapter": "^1.0 || ^2.0",
"typo3fluid/fluid": "^2.7.1"
"typo3fluid/fluid": "^2.7.2"
},
"suggest": {
"ext-fileinfo": "Used for proper file type detection in the file abstraction layer",
......
......@@ -22,7 +22,7 @@
"symfony/dependency-injection": "^5.4",
"typo3/cms-core": "12.0.*@dev",
"typo3/cms-extbase": "12.0.*@dev",
"typo3fluid/fluid": "^2.7.1"
"typo3fluid/fluid": "^2.7.2"
},
"conflict": {
"typo3/cms": "*"
......
......@@ -25,7 +25,7 @@
"symfony/console": "^5.4",
"typo3/cms-backend": "12.0.*@dev",
"typo3/cms-core": "12.0.*@dev",
"typo3fluid/fluid": "^2.7.1"
"typo3fluid/fluid": "^2.7.2"
},
"conflict": {
"typo3/cms": "*"
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment