Commit 89c1244c authored by Christian Kuhn's avatar Christian Kuhn
Browse files

[TASK] Remove unused php-apcu setup from php55 and php56 builds

parent 0ba19dff
#!/bin/bash
set -e
source /pd_build/buildconfig
set -x
minimal_apt_get_install \
make \
php7.0-dev \
#
cd /usr/local/src/
git clone https://github.com/krakjoe/apcu.git
cd apcu
phpize
./configure
make
make install
cd ../
git clone https://github.com/krakjoe/apcu-bc.git
cd apcu-bc
phpize
./configure
make
make install
echo "extension=apcu.so" > /etc/php/7.0/mods-available/apcu.ini
echo "apc.enable_cli=1" >> /etc/php/7.0/mods-available/apcu.ini
echo "apc.slam_defense=0" >> /etc/php/7.0/mods-available/apcu.ini
echo "extension=apc.so" > /etc/php/7.0/mods-available/apc.ini
ln -s /etc/php/7.0/mods-available/apcu.ini /etc/php/7.0/cli/conf.d/20-apcu.ini
ln -s /etc/php/7.0/mods-available/apcu.ini /etc/php/7.0/fpm/conf.d/20-apcu.ini
# apc-bc module must be loaded *after* apcu, have a higher integer in front to enforce this
ln -s /etc/php/7.0/mods-available/apc.ini /etc/php/7.0/cli/conf.d/21-apc.ini
ln -s /etc/php/7.0/mods-available/apc.ini /etc/php/7.0/fpm/conf.d/21-apc.ini
......@@ -37,9 +37,6 @@ minimal_apt_get_install \
## Enable phar writing
sed -i s/';phar.readonly = On'/'phar.readonly = Off'/ /etc/php/5.5/cli/php.ini
# commented for now
# /pd_build/php-apcu.sh
/pd_build/php-finalize.sh
## Configure pool
......
#!/bin/bash
set -e
source /pd_build/buildconfig
set -x
minimal_apt_get_install \
make \
php7.0-dev \
#
cd /usr/local/src/
git clone https://github.com/krakjoe/apcu.git
cd apcu
phpize
./configure
make
make install
cd ../
git clone https://github.com/krakjoe/apcu-bc.git
cd apcu-bc
phpize
./configure
make
make install
echo "extension=apcu.so" > /etc/php/7.0/mods-available/apcu.ini
echo "apc.enable_cli=1" >> /etc/php/7.0/mods-available/apcu.ini
echo "apc.slam_defense=0" >> /etc/php/7.0/mods-available/apcu.ini
echo "extension=apc.so" > /etc/php/7.0/mods-available/apc.ini
ln -s /etc/php/7.0/mods-available/apcu.ini /etc/php/7.0/cli/conf.d/20-apcu.ini
ln -s /etc/php/7.0/mods-available/apcu.ini /etc/php/7.0/fpm/conf.d/20-apcu.ini
# apc-bc module must be loaded *after* apcu, have a higher integer in front to enforce this
ln -s /etc/php/7.0/mods-available/apc.ini /etc/php/7.0/cli/conf.d/21-apc.ini
ln -s /etc/php/7.0/mods-available/apc.ini /etc/php/7.0/fpm/conf.d/21-apc.ini
......@@ -37,9 +37,6 @@ minimal_apt_get_install \
## Enable phar writing
sed -i s/';phar.readonly = On'/'phar.readonly = Off'/ /etc/php/5.6/cli/php.ini
# commented for now
# /pd_build/php-apcu.sh
/pd_build/php-finalize.sh
## Configure pool
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment