Commit f4d7a7ba authored by Christian Kuhn's avatar Christian Kuhn Committed by Richard Haeser
Browse files

[TASK] Declare PHP 8 compatibility

composer req php:"^7.4 || ^8.0"

Note this declares core master PHP 8 compatibility,
even though core is not yet compatible in practice.
The situation should settle until 11.2, though.

Resolves: #93612
Releases: master
Change-Id: Ibd428260ebd48936bb193b1df747283d3b35f410
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/68150


Tested-by: Simon Gilli's avatarSimon Gilli <typo3@gilbertsoft.org>
Tested-by: default avatarTYPO3com <noreply@typo3.com>
Tested-by: core-ci's avatarcore-ci <typo3@b13.com>
Tested-by: Richard Haeser's avatarRichard Haeser <richard@richardhaeser.com>
Reviewed-by: Simon Gilli's avatarSimon Gilli <typo3@gilbertsoft.org>
Reviewed-by: Richard Haeser's avatarRichard Haeser <richard@richardhaeser.com>
parent c2b93650
......@@ -31,7 +31,7 @@
"sort-packages": true
},
"require": {
"php": "^7.4",
"php": "^7.4 || ^8.0",
"ext-PDO": "*",
"ext-json": "*",
"ext-libxml": "*",
......
......@@ -4,7 +4,7 @@
"Read more about it at https://getcomposer.org/doc/01-basic-usage.md#installing-dependencies",
"This file is @generated automatically"
],
"content-hash": "9f6485b5f457a44d5af9510ce5b7befc",
"content-hash": "08adaa4ad79e6abee93486ffe7ae1f37",
"packages": [
{
"name": "bacon/bacon-qr-code",
......@@ -7613,7 +7613,7 @@
"prefer-stable": false,
"prefer-lowest": false,
"platform": {
"php": "^7.4",
"php": "^7.4 || ^8.0",
"ext-pdo": "*",
"ext-json": "*",
"ext-libxml": "*",
......
......@@ -19,7 +19,7 @@
"sort-packages": true
},
"require": {
"php": "^7.4",
"php": "^7.4 || ^8.0",
"ext-PDO": "*",
"ext-json": "*",
"ext-libxml": "*",
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment