Commit a9a5a422 authored by Wouter Wolters's avatar Wouter Wolters Committed by Benni Mack
Browse files

[TASK] Update composer dev dependencies

composer req --dev codeception/codeception:^4.1.21
composer req --dev codeception/module-webdriver:^1.2.1
composer req --dev php-webdriver/webdriver:^1.11.1
composer req --dev composer/package-versions-deprecated:^1.11.99.2

composer req --dev codeception/codeception:^4.1.21 -d typo3/sysext/core --no-update
composer req --dev codeception/module-webdriver:^1.2.1 -d typo3/sysext/core --no-update
composer req --dev php-webdriver/webdriver:^1.11.1 -d typo3/sysext/core --no-update
composer req --dev composer/package-versions-deprecated:^1.11.99.2 -d typo3/sysext/core --no-update

composer u mikey179/vfsstream behat/gherkin composer/semver codeception/stub

Resolves: #94722
Releases: master
Change-Id: I2ec0277374a2bf4e1501e79469826b7ea6360557
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/70234


Tested-by: core-ci's avatarcore-ci <typo3@b13.com>
Tested-by: Christian Kuhn's avatarChristian Kuhn <lolli@schwarzbu.ch>
Tested-by: Benni Mack's avatarBenni Mack <benni@typo3.org>
Reviewed-by: Christian Kuhn's avatarChristian Kuhn <lolli@schwarzbu.ch>
Reviewed-by: Benni Mack's avatarBenni Mack <benni@typo3.org>
parent cf28b8d7
......@@ -4,7 +4,7 @@
"Read more about it at https://getcomposer.org/doc/01-basic-usage.md#installing-dependencies",
"This file is @generated automatically"
],
"content-hash": "caca8f49819e13753fd78bce1f846cff",
"content-hash": "7d4eec0b6b3faa06606b7df0b086c3c1",
"packages": [
{
"name": "bacon/bacon-qr-code",
......@@ -5053,25 +5053,26 @@
"packages-dev": [
{
"name": "behat/gherkin",
"version": "v4.6.1",
"version": "v4.8.0",
"source": {
"type": "git",
"url": "https://github.com/Behat/Gherkin.git",
"reference": "25bdcaf37898b4a939fa3031d5d753ced97e4759"
"reference": "2391482cd003dfdc36b679b27e9f5326bd656acd"
},
"dist": {
"type": "zip",
"url": "https://api.github.com/repos/Behat/Gherkin/zipball/25bdcaf37898b4a939fa3031d5d753ced97e4759",
"reference": "25bdcaf37898b4a939fa3031d5d753ced97e4759",
"url": "https://api.github.com/repos/Behat/Gherkin/zipball/2391482cd003dfdc36b679b27e9f5326bd656acd",
"reference": "2391482cd003dfdc36b679b27e9f5326bd656acd",
"shasum": ""
},
"require": {
"php": ">=5.3.1"
"php": "~7.2|~8.0"
},
"require-dev": {
"phpunit/phpunit": "~4.5|~5",
"symfony/phpunit-bridge": "~2.7|~3|~4",
"symfony/yaml": "~2.3|~3|~4"
"cucumber/cucumber": "dev-gherkin-16.0.0",
"phpunit/phpunit": "~8|~9",
"symfony/phpunit-bridge": "~3|~4|~5",
"symfony/yaml": "~3|~4|~5"
},
"suggest": {
"symfony/yaml": "If you want to parse features, represented in YAML files"
......@@ -5098,7 +5099,7 @@
"homepage": "http://everzet.com"
}
],
"description": "Gherkin DSL parser for PHP 5.3",
"description": "Gherkin DSL parser for PHP",
"homepage": "http://behat.org/",
"keywords": [
"BDD",
......@@ -5110,22 +5111,22 @@
],
"support": {
"issues": "https://github.com/Behat/Gherkin/issues",
"source": "https://github.com/Behat/Gherkin/tree/v4.6.1"
"source": "https://github.com/Behat/Gherkin/tree/v4.8.0"
},
"time": "2020-02-27T11:29:57+00:00"
"time": "2021-02-04T12:44:21+00:00"
},
{
"name": "codeception/codeception",
"version": "4.1.12",
"version": "4.1.21",
"source": {
"type": "git",
"url": "https://github.com/Codeception/Codeception.git",
"reference": "fc550bf6e90d69fbfc8ab7e9e0a330ac98ffafdd"
"reference": "c25f20d842a7e3fa0a8e6abf0828f102c914d419"
},
"dist": {
"type": "zip",
"url": "https://api.github.com/repos/Codeception/Codeception/zipball/fc550bf6e90d69fbfc8ab7e9e0a330ac98ffafdd",
"reference": "fc550bf6e90d69fbfc8ab7e9e0a330ac98ffafdd",
"url": "https://api.github.com/repos/Codeception/Codeception/zipball/c25f20d842a7e3fa0a8e6abf0828f102c914d419",
"reference": "c25f20d842a7e3fa0a8e6abf0828f102c914d419",
"shasum": ""
},
"require": {
......@@ -5145,11 +5146,11 @@
"symfony/yaml": ">=2.7 <6.0"
},
"require-dev": {
"codeception/module-asserts": "*@dev",
"codeception/module-cli": "*@dev",
"codeception/module-db": "*@dev",
"codeception/module-filesystem": "*@dev",
"codeception/module-phpbrowser": "*@dev",
"codeception/module-asserts": "1.*@dev",
"codeception/module-cli": "1.*@dev",
"codeception/module-db": "1.*@dev",
"codeception/module-filesystem": "1.*@dev",
"codeception/module-phpbrowser": "1.*@dev",
"codeception/specify": "~0.3",
"codeception/util-universalframework": "*@dev",
"monolog/monolog": "~1.8",
......@@ -5199,7 +5200,7 @@
],
"support": {
"issues": "https://github.com/Codeception/Codeception/issues",
"source": "https://github.com/Codeception/Codeception/tree/4.1.12"
"source": "https://github.com/Codeception/Codeception/tree/4.1.21"
},
"funding": [
{
......@@ -5207,7 +5208,7 @@
"type": "open_collective"
}
],
"time": "2020-11-16T06:36:57+00:00"
"time": "2021-05-28T17:43:39+00:00"
},
{
"name": "codeception/lib-asserts",
......@@ -5374,22 +5375,22 @@
},
{
"name": "codeception/module-webdriver",
"version": "1.1.4",
"version": "1.2.1",
"source": {
"type": "git",
"url": "https://github.com/Codeception/module-webdriver.git",
"reference": "f719edc1eca033e0dc5fd8d99db122070b1fb933"
"reference": "ebbe729c630415e8caf6b0087e457906f0c6c0c6"
},
"dist": {
"type": "zip",
"url": "https://api.github.com/repos/Codeception/module-webdriver/zipball/f719edc1eca033e0dc5fd8d99db122070b1fb933",
"reference": "f719edc1eca033e0dc5fd8d99db122070b1fb933",
"url": "https://api.github.com/repos/Codeception/module-webdriver/zipball/ebbe729c630415e8caf6b0087e457906f0c6c0c6",
"reference": "ebbe729c630415e8caf6b0087e457906f0c6c0c6",
"shasum": ""
},
"require": {
"codeception/codeception": "^4.0",
"php": ">=5.6.0 <9.0",
"php-webdriver/webdriver": "^1.6.0"
"php-webdriver/webdriver": "^1.8.0"
},
"suggest": {
"codeception/phpbuiltinserver": "Start and stop PHP built-in web server for your tests"
......@@ -5424,9 +5425,9 @@
],
"support": {
"issues": "https://github.com/Codeception/module-webdriver/issues",
"source": "https://github.com/Codeception/module-webdriver/tree/1.1.4"
"source": "https://github.com/Codeception/module-webdriver/tree/1.2.1"
},
"time": "2020-11-16T06:50:15+00:00"
"time": "2021-04-23T17:30:57+00:00"
},
{
"name": "codeception/phpunit-wrapper",
......@@ -5479,16 +5480,16 @@
},
{
"name": "codeception/stub",
"version": "3.6.1",
"version": "3.7.0",
"source": {
"type": "git",
"url": "https://github.com/Codeception/Stub.git",
"reference": "a3ba01414cbee76a1bced9f9b6b169cc8d203880"
"reference": "468dd5fe659f131fc997f5196aad87512f9b1304"
},
"dist": {
"type": "zip",
"url": "https://api.github.com/repos/Codeception/Stub/zipball/a3ba01414cbee76a1bced9f9b6b169cc8d203880",
"reference": "a3ba01414cbee76a1bced9f9b6b169cc8d203880",
"url": "https://api.github.com/repos/Codeception/Stub/zipball/468dd5fe659f131fc997f5196aad87512f9b1304",
"reference": "468dd5fe659f131fc997f5196aad87512f9b1304",
"shasum": ""
},
"require": {
......@@ -5507,30 +5508,30 @@
"description": "Flexible Stub wrapper for PHPUnit's Mock Builder",
"support": {
"issues": "https://github.com/Codeception/Stub/issues",
"source": "https://github.com/Codeception/Stub/tree/3.6.1"
"source": "https://github.com/Codeception/Stub/tree/3.7.0"
},
"time": "2020-02-07T18:42:28+00:00"
"time": "2020-07-03T15:54:43+00:00"
},
{
"name": "composer/package-versions-deprecated",
"version": "1.10.99",
"version": "1.11.99.2",
"source": {
"type": "git",
"url": "https://github.com/composer/package-versions-deprecated.git",
"reference": "dd51b4443d58b34b6d9344cf4c288e621c9a826f"
"reference": "c6522afe5540d5fc46675043d3ed5a45a740b27c"
},
"dist": {
"type": "zip",
"url": "https://api.github.com/repos/composer/package-versions-deprecated/zipball/dd51b4443d58b34b6d9344cf4c288e621c9a826f",
"reference": "dd51b4443d58b34b6d9344cf4c288e621c9a826f",
"url": "https://api.github.com/repos/composer/package-versions-deprecated/zipball/c6522afe5540d5fc46675043d3ed5a45a740b27c",
"reference": "c6522afe5540d5fc46675043d3ed5a45a740b27c",
"shasum": ""
},
"require": {
"composer-plugin-api": "^1.1.0 || ^2.0",
"php": "^7"
"php": "^7 || ^8"
},
"replace": {
"ocramius/package-versions": "1.10.99"
"ocramius/package-versions": "1.11.99"
},
"require-dev": {
"composer/composer": "^1.9.3 || ^2.0@dev",
......@@ -5566,7 +5567,7 @@
"description": "Composer plugin that provides efficient querying for installed package versions (no runtime IO)",
"support": {
"issues": "https://github.com/composer/package-versions-deprecated/issues",
"source": "https://github.com/composer/package-versions-deprecated/tree/1.10.99"
"source": "https://github.com/composer/package-versions-deprecated/tree/1.11.99.2"
},
"funding": [
{
......@@ -5582,20 +5583,20 @@
"type": "tidelift"
}
],
"time": "2020-07-15T08:39:18+00:00"
"time": "2021-05-24T07:46:03+00:00"
},
{
"name": "composer/semver",
"version": "3.2.4",
"version": "3.2.5",
"source": {
"type": "git",
"url": "https://github.com/composer/semver.git",
"reference": "a02fdf930a3c1c3ed3a49b5f63859c0c20e10464"
"reference": "31f3ea725711245195f62e54ffa402d8ef2fdba9"
},
"dist": {
"type": "zip",
"url": "https://api.github.com/repos/composer/semver/zipball/a02fdf930a3c1c3ed3a49b5f63859c0c20e10464",
"reference": "a02fdf930a3c1c3ed3a49b5f63859c0c20e10464",
"url": "https://api.github.com/repos/composer/semver/zipball/31f3ea725711245195f62e54ffa402d8ef2fdba9",
"reference": "31f3ea725711245195f62e54ffa402d8ef2fdba9",
"shasum": ""
},
"require": {
......@@ -5647,7 +5648,7 @@
"support": {
"irc": "irc://irc.freenode.org/composer",
"issues": "https://github.com/composer/semver/issues",
"source": "https://github.com/composer/semver/tree/3.2.4"
"source": "https://github.com/composer/semver/tree/3.2.5"
},
"funding": [
{
......@@ -5663,7 +5664,7 @@
"type": "tidelift"
}
],
"time": "2020-11-13T08:59:24+00:00"
"time": "2021-05-24T12:41:47+00:00"
},
{
"name": "composer/xdebug-handler",
......@@ -5882,16 +5883,16 @@
},
{
"name": "mikey179/vfsstream",
"version": "v1.6.8",
"version": "v1.6.9",
"source": {
"type": "git",
"url": "https://github.com/bovigo/vfsStream.git",
"reference": "231c73783ebb7dd9ec77916c10037eff5a2b6efe"
"reference": "2257e326dc3d0f50e55d0a90f71e37899f029718"
},
"dist": {
"type": "zip",
"url": "https://api.github.com/repos/bovigo/vfsStream/zipball/231c73783ebb7dd9ec77916c10037eff5a2b6efe",
"reference": "231c73783ebb7dd9ec77916c10037eff5a2b6efe",
"url": "https://api.github.com/repos/bovigo/vfsStream/zipball/2257e326dc3d0f50e55d0a90f71e37899f029718",
"reference": "2257e326dc3d0f50e55d0a90f71e37899f029718",
"shasum": ""
},
"require": {
......@@ -5929,7 +5930,7 @@
"source": "https://github.com/bovigo/vfsStream/tree/master",
"wiki": "https://github.com/bovigo/vfsStream/wiki"
},
"time": "2019-10-30T15:31:00+00:00"
"time": "2021-07-16T08:08:02+00:00"
},
{
"name": "myclabs/deep-copy",
......@@ -6157,16 +6158,16 @@
},
{
"name": "php-webdriver/webdriver",
"version": "1.9.0",
"version": "1.11.1",
"source": {
"type": "git",
"url": "https://github.com/php-webdriver/php-webdriver.git",
"reference": "e3633154554605274cc9d59837f55a7427d72003"
"reference": "da16e39968f8dd5cfb7d07eef91dc2b731c69880"
},
"dist": {
"type": "zip",
"url": "https://api.github.com/repos/php-webdriver/php-webdriver/zipball/e3633154554605274cc9d59837f55a7427d72003",
"reference": "e3633154554605274cc9d59837f55a7427d72003",
"url": "https://api.github.com/repos/php-webdriver/php-webdriver/zipball/da16e39968f8dd5cfb7d07eef91dc2b731c69880",
"reference": "da16e39968f8dd5cfb7d07eef91dc2b731c69880",
"shasum": ""
},
"require": {
......@@ -6182,7 +6183,7 @@
},
"require-dev": {
"friendsofphp/php-cs-fixer": "^2.0",
"ondram/ci-detector": "^2.1 || ^3.5",
"ondram/ci-detector": "^2.1 || ^3.5 || ^4.0",
"php-coveralls/php-coveralls": "^2.4",
"php-mock/php-mock-phpunit": "^1.1 || ^2.0",
"php-parallel-lint/php-parallel-lint": "^1.2",
......@@ -6194,11 +6195,6 @@
"ext-SimpleXML": "For Firefox profile creation"
},
"type": "library",
"extra": {
"branch-alias": {
"dev-main": "1.8.x-dev"
}
},
"autoload": {
"psr-4": {
"Facebook\\WebDriver\\": "lib/"
......@@ -6222,9 +6218,9 @@
],
"support": {
"issues": "https://github.com/php-webdriver/php-webdriver/issues",
"source": "https://github.com/php-webdriver/php-webdriver/tree/1.9.0"
"source": "https://github.com/php-webdriver/php-webdriver/tree/1.11.1"
},
"time": "2020-11-19T15:21:05+00:00"
"time": "2021-05-21T15:12:49+00:00"
},
{
"name": "phpspec/prophecy",
......@@ -8257,5 +8253,5 @@
"platform-overrides": {
"php": "7.4.1"
},
"plugin-api-version": "2.0.0"
"plugin-api-version": "2.1.0"
}
......@@ -71,13 +71,14 @@
"typo3fluid/fluid": "^2.7.0"
},
"require-dev": {
"codeception/codeception": "^4.1.12",
"codeception/codeception": "^4.1.21",
"codeception/lib-asserts": "^1.13.2",
"codeception/module-asserts": "^1.3.1",
"codeception/module-filesystem": "^1.0.3",
"codeception/module-webdriver": "^1.1.4",
"codeception/module-webdriver": "^1.2.1",
"composer/package-versions-deprecated": "^1.11.99.2",
"friendsofphp/php-cs-fixer": "^2.19 || ^3.0",
"php-webdriver/webdriver": "^1.9.0",
"php-webdriver/webdriver": "^1.11.1",
"phpspec/prophecy": "^1.12.2",
"phpspec/prophecy-phpunit": "^2.0",
"phpstan/phpstan": "^0.12.64",
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment