Commit 853b5193 authored by crell's avatar crell
Browse files

[TASK] Update PHP Parser to the latest release.

The current version of PHP Parser we're using doesn't support
all the new PHP 8.1 syntax yet.  So update it.

Used commands:
composer req "nikic/php-parser":"^4.13.2"
composer req "nikic/php-parser":"^4.13.2" -d typo3/sysext/core --no-update
composer req "nikic/php-parser":"^4.13.2" -d typo3/sysext/install --no-update

Resolves: #96612
Releases: master
Change-Id: Ifb4afebccef0b2e7e6d28e597a85813d06bcb5d4
parent ba2cae54
Pipeline #22365 passed with stages
in 11 minutes and 1 second
......@@ -4,7 +4,7 @@
"Read more about it at https://getcomposer.org/doc/01-basic-usage.md#installing-dependencies",
"This file is @generated automatically"
],
"content-hash": "17b6f73676ad8018fade592602b16cef",
"content-hash": "b258e92dde2904803082b1cf33525642",
"packages": [
{
"name": "bacon/bacon-qr-code",
......@@ -1225,16 +1225,16 @@
},
{
"name": "nikic/php-parser",
"version": "v4.12.0",
"version": "v4.13.2",
"source": {
"type": "git",
"url": "https://github.com/nikic/PHP-Parser.git",
"reference": "6608f01670c3cc5079e18c1dab1104e002579143"
"reference": "210577fe3cf7badcc5814d99455df46564f3c077"
},
"dist": {
"type": "zip",
"url": "https://api.github.com/repos/nikic/PHP-Parser/zipball/6608f01670c3cc5079e18c1dab1104e002579143",
"reference": "6608f01670c3cc5079e18c1dab1104e002579143",
"url": "https://api.github.com/repos/nikic/PHP-Parser/zipball/210577fe3cf7badcc5814d99455df46564f3c077",
"reference": "210577fe3cf7badcc5814d99455df46564f3c077",
"shasum": ""
},
"require": {
......@@ -1275,9 +1275,9 @@
],
"support": {
"issues": "https://github.com/nikic/PHP-Parser/issues",
"source": "https://github.com/nikic/PHP-Parser/tree/v4.12.0"
"source": "https://github.com/nikic/PHP-Parser/tree/v4.13.2"
},
"time": "2021-07-21T10:44:31+00:00"
"time": "2021-11-30T19:35:32+00:00"
},
{
"name": "phpdocumentor/reflection-common",
......@@ -8337,5 +8337,5 @@
"platform-overrides": {
"php": "8.1.1"
},
"plugin-api-version": "2.2.0"
"plugin-api-version": "2.1.0"
}
......@@ -40,7 +40,7 @@
"guzzlehttp/psr7": "^1.7.0 || ^2.0",
"lolli42/finediff": "^1.0",
"masterminds/html5": "^2.7.5",
"nikic/php-parser": "^4.10.4",
"nikic/php-parser": "^4.13.2",
"psr/container": "^1.1 || ^2.0",
"psr/event-dispatcher": "^1.0",
"psr/http-client": "^1.0",
......
......@@ -21,7 +21,7 @@
"require": {
"doctrine/dbal": "^3.2",
"guzzlehttp/promises": "^1.4.0",
"nikic/php-parser": "^4.10.4",
"nikic/php-parser": "^4.13.2",
"symfony/finder": "^5.4",
"symfony/http-foundation": "^5.4",
"typo3/cms-core": "12.0.*@dev",
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment