Commit 4b4385b4 authored by Benni Mack's avatar Benni Mack
Browse files

[TASK] Require symfony components with 5.3.0 or higher

TYPO3 v11 will require symfony 5.3.0 (and hopefully
further versions once they will be released).

Used composer command:

> composer req -W "symfony/config:^5.3.0" \
"symfony/console:^5.3.0" \
"symfony/dependency-injection:^5.3.0" \
"symfony/expression-language:^5.3.0" \
"symfony/finder:^5.3.0" \
"symfony/http-foundation:^5.3.0" \
"symfony/mailer:^5.3.0" \
"symfony/mime:^5.3.0" \
"symfony/property-access:^5.3.0" \
"symfony/property-info:^5.3.0" \
"symfony/routing:^5.3.0" \
"symfony/var-dumper:^5.3.0" \
"symfony/yaml:^5.3.0"

Resolves: #94340
Releases: master
Change-Id: I3777975d144b3424910043f2445d576f885f0e41
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/69490


Tested-by: core-ci's avatarcore-ci <typo3@b13.com>
Tested-by: Christian Kuhn's avatarChristian Kuhn <lolli@schwarzbu.ch>
Tested-by: Benni Mack's avatarBenni Mack <benni@typo3.org>
Reviewed-by: Christian Kuhn's avatarChristian Kuhn <lolli@schwarzbu.ch>
Reviewed-by: Benni Mack's avatarBenni Mack <benni@typo3.org>
parent 82fe6c57
This diff is collapsed.
......@@ -22,7 +22,7 @@
"psr/http-message": "^1.0",
"psr/http-server-handler": "^1.0",
"psr/http-server-middleware": "^1.0",
"symfony/var-dumper": "^5.2",
"symfony/var-dumper": "^5.3.0",
"typo3/cms-backend": "11.3.*@dev",
"typo3/cms-core": "11.3.*@dev",
"typo3/cms-fluid": "11.3.*@dev",
......
......@@ -44,21 +44,21 @@
"psr/http-server-handler": "^1.0",
"psr/http-server-middleware": "^1.0",
"psr/log": "^1.0",
"symfony/config": "^5.2",
"symfony/console": "^5.2",
"symfony/dependency-injection": "^5.2",
"symfony/config": "^5.3.0",
"symfony/console": "^5.3.0",
"symfony/dependency-injection": "^5.3.0",
"symfony/event-dispatcher-contracts": "^1.1 || ^2.0",
"symfony/expression-language": "^5.2",
"symfony/finder": "^5.2",
"symfony/http-foundation": "^5.2",
"symfony/mailer": "^5.2",
"symfony/mime": "^5.2",
"symfony/expression-language": "^5.3.0",
"symfony/finder": "^5.3.0",
"symfony/http-foundation": "^5.3.0",
"symfony/mailer": "^5.3.0",
"symfony/mime": "^5.3.0",
"symfony/polyfill-intl-icu": "^1.6",
"symfony/polyfill-intl-idn": "^1.10",
"symfony/polyfill-intl-normalizer": "^1.22",
"symfony/polyfill-mbstring": "^1.2",
"symfony/routing": "^5.2",
"symfony/yaml": "^5.2",
"symfony/routing": "^5.3.0",
"symfony/yaml": "^5.3.0",
"typo3/class-alias-loader": "^1.0",
"typo3/cms-cli": "^3.0",
"typo3/cms-composer-installers": "^2.0 || ^3.0",
......
......@@ -21,9 +21,9 @@
"require": {
"phpdocumentor/reflection-docblock": "^5.2",
"phpdocumentor/type-resolver": "^1.4",
"symfony/dependency-injection": "^5.2",
"symfony/property-access": "^5.2",
"symfony/property-info": "^5.2",
"symfony/dependency-injection": "^5.3.0",
"symfony/property-access": "^5.3.0",
"symfony/property-info": "^5.3.0",
"typo3/cms-core": "11.3.*@dev"
},
"suggest": {
......
......@@ -19,7 +19,7 @@
"sort-packages": true
},
"require": {
"symfony/dependency-injection": "^5.2",
"symfony/dependency-injection": "^5.3.0",
"typo3/cms-core": "11.3.*@dev",
"typo3/cms-extbase": "11.3.*@dev",
"typo3fluid/fluid": "^2.7.0"
......
......@@ -20,7 +20,7 @@
},
"require": {
"psr/http-message": "^1.0",
"symfony/expression-language": "^5.2",
"symfony/expression-language": "^5.3.0",
"typo3/cms-core": "11.3.*@dev"
},
"suggest": {
......
......@@ -21,7 +21,7 @@
"require": {
"doctrine/dbal": "^2.12",
"nikic/php-parser": "^4.10.4",
"symfony/finder": "^5.2",
"symfony/finder": "^5.3.0",
"typo3/cms-core": "11.3.*@dev",
"typo3/cms-extbase": "11.3.*@dev",
"typo3/cms-fluid": "11.3.*@dev"
......
......@@ -22,7 +22,7 @@
"doctrine/dbal": "^2.12",
"psr/http-message": "^1.0",
"psr/log": "^1.0",
"symfony/console": "^5.2",
"symfony/console": "^5.3.0",
"typo3/cms-backend": "11.3.*@dev",
"typo3/cms-core": "11.3.*@dev",
"typo3fluid/fluid": "^2.7.0"
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment