Commit 220d8802 authored by Benni Mack's avatar Benni Mack
Browse files

[TASK] Require symfony components v5.2 or higher

In order to set up the dependencies for the upcoming
TYPO3 v11 release, Core now requires symfony components in version
5.2 or higher.

Used composer command:

composer require symfony/mime:^5.2 symfony/mailer:^5.2 symfony/http-foundation:^5.2 symfony/finder:^5.2 symfony/expression-language:^5.2 symfony/dependency-injection:^5.2 symfony/console:^5.2 symfony/config:^5.2 symfony/routing:^5.2 symfony/var-dumper:^5.2 symfony/yaml:^5.2 symfony/property-access:^5.2 symfony/property-info:^5.2 --update-with-all-dependencies

Resolves: #92994
Releases: master
Change-Id: Ia54001583919d2da9b2107e0486fe7744a2ef220
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/67006


Reviewed-by: Oliver Klee's avatarOliver Klee <typo3-coding@oliverklee.de>
Reviewed-by: Anja Leichsenring's avatarAnja Leichsenring <aleichsenring@ab-softlab.de>
Reviewed-by: Benni Mack's avatarBenni Mack <benni@typo3.org>
Tested-by: default avatarTYPO3com <noreply@typo3.com>
Tested-by: Anja Leichsenring's avatarAnja Leichsenring <aleichsenring@ab-softlab.de>
Tested-by: Benni Mack's avatarBenni Mack <benni@typo3.org>
parent 290b9b4b
This diff is collapsed.
......@@ -27,7 +27,7 @@
"psr/http-message": "^1.0",
"psr/http-server-handler": "^1.0",
"psr/http-server-middleware": "^1.0",
"symfony/var-dumper": "^4.4 || ^5.0"
"symfony/var-dumper": "^5.2"
},
"conflict": {
"typo3/cms": "*"
......
......@@ -42,20 +42,20 @@
"psr/http-server-handler": "^1.0",
"psr/http-server-middleware": "^1.0",
"psr/log": "^1.0",
"symfony/config": "^4.4 || ^5.0",
"symfony/console": "^4.4 || ^5.0",
"symfony/dependency-injection": "^4.4 || ^5.0",
"symfony/config": "^5.2",
"symfony/console": "^5.2",
"symfony/dependency-injection": "^5.2",
"symfony/event-dispatcher-contracts": "^1.1 || ^2.0",
"symfony/expression-language": "^4.4 || ^5.0",
"symfony/finder": "^4.4 || ^5.0",
"symfony/http-foundation": "^4.4 || ^5.0",
"symfony/mailer": "^4.4 || ^5.0",
"symfony/mime": "^4.4 || ^5.0",
"symfony/expression-language": "^5.2",
"symfony/finder": "^5.2",
"symfony/http-foundation": "^5.2",
"symfony/mailer": "^5.2",
"symfony/mime": "^5.2",
"symfony/polyfill-intl-icu": "^1.6",
"symfony/polyfill-intl-idn": "^1.10",
"symfony/polyfill-mbstring": "^1.2",
"symfony/routing": "^4.4 || ^5.0",
"symfony/yaml": "^4.4 || ^5.0",
"symfony/routing": "^5.2",
"symfony/yaml": "^5.2",
"typo3/class-alias-loader": "^1.0",
"typo3/cms-cli": "^2.0",
"typo3/cms-composer-installers": "^2.0 || ^3.0",
......
......@@ -21,9 +21,9 @@
"require": {
"phpdocumentor/reflection-docblock": "^5.1.0",
"phpdocumentor/type-resolver": "^1.1.0",
"symfony/dependency-injection": "^4.4 || ^5.0",
"symfony/property-access": "^4.4 || ^5.0",
"symfony/property-info": "^4.4 || ^5.0",
"symfony/dependency-injection": "^5.2",
"symfony/property-access": "^5.2",
"symfony/property-info": "^5.2",
"typo3/cms-core": "11.0.*@dev"
},
"suggest": {
......
......@@ -19,7 +19,7 @@
"sort-packages": true
},
"require": {
"symfony/dependency-injection": "^4.4 || ^5.0",
"symfony/dependency-injection": "^5.2",
"typo3/cms-core": "11.0.*@dev",
"typo3/cms-extbase": "11.0.*@dev",
"typo3fluid/fluid": "^2.6.10 || ^3"
......
......@@ -20,7 +20,7 @@
},
"require": {
"psr/http-message": "^1.0",
"symfony/expression-language": "^4.4 || ^5.0",
"symfony/expression-language": "^5.2",
"typo3/cms-core": "11.0.*@dev"
},
"suggest": {
......
......@@ -21,7 +21,7 @@
"require": {
"doctrine/dbal": "^2.12",
"nikic/php-parser": "^4.3",
"symfony/finder": "^4.4 || ^5.0",
"symfony/finder": "^5.2",
"typo3/cms-core": "11.0.*@dev",
"typo3/cms-extbase": "11.0.*@dev",
"typo3/cms-fluid": "11.0.*@dev"
......
......@@ -22,7 +22,7 @@
"doctrine/dbal": "^2.12",
"psr/http-message": "^1.0",
"psr/log": "^1.0",
"symfony/console": "^4.4 || ^5.0",
"symfony/console": "^5.2",
"typo3/cms-backend": "11.0.*@dev",
"typo3/cms-core": "11.0.*@dev",
"typo3fluid/fluid": "^2.6.10 || ^3"
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment