Merge branch '541-do-not-allow-to-upload-extensions-with-invalid-versions' into 'develop'

[BUGFIX] Make valid version check more restrictive

Closes #541

See merge request !691
10 jobs for develop in 11 minutes and 34 seconds (queued for 10 seconds)