Commit 40097887 authored by Thomas Löffler's avatar Thomas Löffler
Browse files

Remove "-dev" from development release

parent b4438d19
Pipeline #11588 passed with stages
in 5 minutes and 48 seconds
......@@ -830,7 +830,7 @@ class Extension extends \TYPO3\CMS\Extbase\DomainObject\AbstractEntity implement
}
if ($ltsVersionService->getLatestDevelopmentVersion(true) > VersionNumberUtility::convertVersionNumberToInteger($ltsVersionService->coreData['latest_lts'])
&& VersionUtility::doesExtensionSupportTypo3Version($this, $ltsVersionService->getLatestDevelopmentVersion(true))) {
$supportedVersions[$ltsVersionService->getLatestDevelopmentVersion()] = ['label' => $ltsVersionService->getLatestDevelopmentVersion() . '-dev', 'badgeClass' => 'primary'];
$supportedVersions[$ltsVersionService->getLatestDevelopmentVersion()] = ['label' => $ltsVersionService->getLatestDevelopmentVersion(), 'badgeClass' => 'primary'];
}
array_unique($supportedVersions);
......
......@@ -837,7 +837,7 @@ class Version extends \TYPO3\CMS\Extbase\DomainObject\AbstractEntity
if ($this->doesSupportTypo3Version($latestDevelopmentVersion) && !in_array($latestDevelopmentVersion, $currentStableVersions, true)) {
$supportedTypo3Versions[$ltsVersionService->getVersionLabelOfRelease($latestDevelopmentVersion)] = [
'label' => $ltsVersionService->getVersionLabelOfRelease($latestDevelopmentVersion) . '-dev',
'label' => $ltsVersionService->getVersionLabelOfRelease($latestDevelopmentVersion),
'badgeClass' => 'info'
];
}
......
......@@ -138,7 +138,7 @@ class TerIndexer extends \ApacheSolrForTypo3\Solr\IndexQueue\Indexer
}
if ($ltsVersionService->getLatestDevelopmentVersion(true) > VersionNumberUtility::convertVersionNumberToInteger($ltsVersionService->coreData['latest_lts'])
&& VersionUtility::doesExtensionSupportTypo3Version($extension, $ltsVersionService->getLatestDevelopmentVersion(true))) {
$supportDevVersion = $ltsVersionService->getLatestDevelopmentVersion() . '-dev';
$supportDevVersion = $ltsVersionService->getLatestDevelopmentVersion();
}
foreach ($ltsVersionService->getELTSVersions() as $versionNumber) {
if (VersionUtility::doesExtensionSupportTypo3Version($extension, $versionNumber)) {
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment