Commit cf40e083 authored by Andreas Fernandez's avatar Andreas Fernandez Committed by Georg Ringer
Browse files

[TASK] Update CSS tooling

This patch updates some CSS tools to the current version and creates new
CSS builds.

Executed commands:

  yarn add --dev node-sass \
    grunt-stylelint@^0.11.0 \
    grunt-sass@^3.1.0 \
    stylefmt@^6.0.0 \
    autoprefixer@^9.6

  yarn upgrade --pattern postcss --latest

This patch also updates the list of supported browsers, raising minimum
iOS version and dropping Internet Explorer completely.

Resolves: #89251
Releases: master
Change-Id: I5e87a94184b2fe76c57b602266bebbc2c43390de
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/61800


Tested-by: default avatarTYPO3com <noreply@typo3.com>
Tested-by: Anja Leichsenring's avatarAnja Leichsenring <aleichsenring@ab-softlab.de>
Tested-by: Georg Ringer's avatarGeorg Ringer <georg.ringer@gmail.com>
Reviewed-by: Anja Leichsenring's avatarAnja Leichsenring <aleichsenring@ab-softlab.de>
Reviewed-by: Georg Ringer's avatarGeorg Ringer <georg.ringer@gmail.com>
parent b442a2a1
last 2 version
Firefox ESR
iOS >= 11
not ie > 0
not dead
......@@ -13,6 +13,8 @@
module.exports = function (grunt) {
const sass = require('node-sass');
/**
* Grunt stylefmt task
*/
......@@ -82,6 +84,7 @@ module.exports = function (grunt) {
},
sass: {
options: {
implementation: sass,
outputStyle: 'expanded',
precision: 8,
includePaths: [
......@@ -131,18 +134,7 @@ module.exports = function (grunt) {
options: {
map: false,
processors: [
require('autoprefixer')({
browsers: [
'Chrome >= 57',
'Firefox >= 52',
'Edge >= 14',
'Explorer >= 11',
'iOS >= 9',
'Safari >= 8',
'Android >= 4',
'Opera >= 43'
]
}),
require('autoprefixer')(),
require('postcss-clean')({
rebase: false,
level: {
......
......@@ -25,7 +25,7 @@
"@types/nprogress": "^0.0.29",
"@types/requirejs": "*",
"@typo3/icons": "^1.10.0",
"autoprefixer": "^6.3.7",
"autoprefixer": "^9.6",
"autosize": "^3.0.21",
"bootstrap-sass": "^3.4.1",
"bootstrap-slider": "^9.7.3",
......@@ -47,9 +47,9 @@
"grunt-lintspaces": "^0.8.5",
"grunt-npm-install": "^0.3.1",
"grunt-npmcopy": "^0.1.0",
"grunt-postcss": "^0.8.0",
"grunt-sass": "^2.0.0",
"grunt-stylelint": "^0.7.0",
"grunt-postcss": "^0.9.0",
"grunt-sass": "^3.1.0",
"grunt-stylelint": "^0.11.0",
"grunt-terser": "^0.1.0",
"grunt-tslint": "^5.0.1",
"imagesloaded": "^4.1.1",
......@@ -68,13 +68,14 @@
"karma-safari-launcher": "^1.0.0",
"moment": "^2.18.1",
"moment-timezone": "0.5.20",
"node-sass": "^4.12.0",
"npm-font-source-sans-pro": "^1.0.2",
"nprogress": "^0.2.0",
"postcss-banner": "^3.0.0",
"postcss-banner": "^3.0.1",
"postcss-clean": "^1.1.0",
"requirejs": "^2.3.3",
"sortablejs": "^1.9.0",
"stylefmt": "^5.3.0",
"stylefmt": "^6.0.0",
"taboverride": "^4.0.3",
"tagsort": "1.4.0",
"tslint": "^5.10.0",
......
This diff is collapsed.
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment