Commit ce24ce8f authored by Andreas Fernandez's avatar Andreas Fernandez Committed by Oliver Bartsch
Browse files

[TASK] Update bootstrap to 5.0.2 and @types/bootstrap to 5.0.16

This patch updates bootstrap to version 5.0.2, introducing several
bugfixes. See https://github.com/twbs/bootstrap/releases/tag/v5.0.2 for
further reference.

Executed commands:

    yarn add bootstrap@^5.0.2 --cwd Build/
    yarn add --dev @types/bootstrap@^5.0.16 --cwd Build/

Resolves: #94468
Releases: master
Change-Id: Ib212aa0b784ae504b6c128ad91001926d2a4e0ea
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/69687


Tested-by: core-ci's avatarcore-ci <typo3@b13.com>
Tested-by: Benni Mack's avatarBenni Mack <benni@typo3.org>
Tested-by: Oliver Bartsch's avatarOliver Bartsch <bo@cedev.de>
Reviewed-by: Benni Mack's avatarBenni Mack <benni@typo3.org>
Reviewed-by: Oliver Bartsch's avatarOliver Bartsch <bo@cedev.de>
parent 5d3eff1b
......@@ -13,7 +13,7 @@
},
"devDependencies": {
"@rollup/plugin-replace": "^2.4.2",
"@types/bootstrap": "^5.0.13",
"@types/bootstrap": "^5.0.16",
"@types/chosen-js": "^1.8.1",
"@types/chrome": "^0.0.123",
"@types/ckeditor": "^4.9.10",
......@@ -82,7 +82,7 @@
"@popperjs/core": "^2.9.1",
"@typo3/icons": "^2.2.2",
"autosize": "^4.0.2",
"bootstrap": "^5.0.1",
"bootstrap": "^5.0.2",
"broadcastchannel-polyfill": "^1.0.0",
"chart.js": "^2.9.3",
"chosen-js": "^1.8.7",
......
......@@ -444,12 +444,7 @@
"@nodelib/fs.scandir" "2.1.3"
fastq "^1.6.0"
"@popperjs/core@2.6.0":
version "2.6.0"
resolved "https://registry.yarnpkg.com/@popperjs/core/-/core-2.6.0.tgz#f022195afdfc942e088ee2101285a1d31c7d727f"
integrity sha512-cPqjjzuFWNK3BSKLm0abspP0sp/IGOli4p5I5fKFAzdS8fvjdOwDCfZqAaIiXd9lPkOWi3SUUfZof3hEb7J/uw==
"@popperjs/core@^2.9.1":
"@popperjs/core@^2.9.1", "@popperjs/core@^2.9.2":
version "2.9.2"
resolved "https://registry.yarnpkg.com/@popperjs/core/-/core-2.9.2.tgz#adea7b6953cbb34651766b0548468e743c6a2353"
integrity sha512-VZMYa7+fXHdwIq1TDhSXoVmSPEGM/aa+6Aiq3nVVJ9bXr24zScr+NlKFKC3iPljA7ho/GAZr+d2jOf5GIRC30Q==
......@@ -491,12 +486,12 @@
remark "^13.0.0"
unist-util-find-all-after "^3.0.2"
"@types/bootstrap@^5.0.13":
version "5.0.13"
resolved "https://registry.yarnpkg.com/@types/bootstrap/-/bootstrap-5.0.13.tgz#493e6b82a56589d9bdbb06f3bc6956002cf73883"
integrity sha512-LsSZyG0K7VVi4HKHFr8b8LN2EuLqb79XbC+D7/FvTI5u8G1HKJGfxggcL+T4Kdmi/ZAfEsOL/0bysIf5OndO4g==
"@types/bootstrap@^5.0.16":
version "5.0.16"
resolved "https://registry.yarnpkg.com/@types/bootstrap/-/bootstrap-5.0.16.tgz#06e0a4345b4c5c8a709485de73dd7755c1a980d7"
integrity sha512-uhtf4ELsDQVJiSDKHcuTukSn1J130q8efihDD2COk7t3XCHOSvdWqy0alIRqhzfQ3ZCUybVolLrVG4EsIF87yQ==
dependencies:
"@popperjs/core" "2.6.0"
"@popperjs/core" "^2.9.2"
"@types/jquery" "*"
"@types/chosen-js@^1.8.1":
......@@ -1316,10 +1311,10 @@ boolbase@^1.0.0, boolbase@~1.0.0:
resolved "https://registry.yarnpkg.com/boolbase/-/boolbase-1.0.0.tgz#68dff5fbe60c51eb37725ea9e3ed310dcc1e776e"
integrity sha1-aN/1++YMUes3cl6p4+0xDcwed24=
bootstrap@^5.0.1:
version "5.0.1"
resolved "https://registry.yarnpkg.com/bootstrap/-/bootstrap-5.0.1.tgz#e7939d599119dc818a90478a2a299bdaff037e09"
integrity sha512-Fl79+wsLOZKoiU345KeEaWD0ik8WKRI5zm0YSPj2oF1Qr+BO7z0fco6GbUtqjoG1h4VI89PeKJnMsMMVQdKKTw==
bootstrap@^5.0.2:
version "5.0.2"
resolved "https://registry.yarnpkg.com/bootstrap/-/bootstrap-5.0.2.tgz#aff23d5e0e03c31255ad437530ee6556e78e728e"
integrity sha512-1Ge963tyEQWJJ+8qtXFU6wgmAVj9gweEjibUdbmcCEYsn38tVwRk8107rk2vzt6cfQcRr3SlZ8aQBqaD8aqf+Q==
boxen@^1.2.1:
version "1.3.0"
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment