Commit 3f2d98c4 authored by Aimeos's avatar Aimeos Committed by Susanne Moog
Browse files

[TASK] Consistent version restrictions for PSR packages

    composer require "psr/http-message":"^1.0"
    composer require "psr/log":"^1.0"

Releases: master
Resolves: #89626
Change-Id: Ieeceddba8ea49da1eac66f113f1c22623f479582
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/62260


Tested-by: default avatarTYPO3com <noreply@typo3.com>
Tested-by: Andreas Fernandez's avatarAndreas Fernandez <a.fernandez@scripting-base.de>
Tested-by: Susanne Moog's avatarSusanne Moog <look@susi.dev>
Reviewed-by: Andreas Fernandez's avatarAndreas Fernandez <a.fernandez@scripting-base.de>
Reviewed-by: Susanne Moog's avatarSusanne Moog <look@susi.dev>
parent 9b426a5a
......@@ -4,7 +4,7 @@
"Read more about it at https://getcomposer.org/doc/01-basic-usage.md#installing-dependencies",
"This file is @generated automatically"
],
"content-hash": "c0ef861e95751f5b4784a545886acdfe",
"content-hash": "5e930083e33c28b1c7137aff379cf235",
"packages": [
{
"name": "cogpowered/finediff",
......
......@@ -18,7 +18,7 @@
"typo3/cms-fluid": "10.2.*@dev",
"typo3/cms-frontend": "10.2.*@dev",
"typo3fluid/fluid": "^2.6.6",
"psr/http-message": "~1.0",
"psr/http-message": "^1.0",
"psr/http-server-handler": "^1.0",
"psr/http-server-middleware": "^1.0"
},
......
......@@ -30,10 +30,10 @@
"psr/event-dispatcher": "^1.0",
"psr/http-client": "^1.0",
"psr/http-factory": "^1.0",
"psr/http-message": "~1.0",
"psr/http-message": "^1.0",
"psr/http-server-handler": "^1.0",
"psr/http-server-middleware": "^1.0",
"psr/log": "~1.0.0",
"psr/log": "^1.0",
"symfony/config": "^4.1",
"symfony/console": "^4.1",
"symfony/dependency-injection": "^4.1",
......
......@@ -13,7 +13,7 @@
"sort-packages": true
},
"require": {
"psr/http-message": "~1.0",
"psr/http-message": "^1.0",
"symfony/expression-language": "^4.1",
"typo3/cms-core": "10.2.*@dev"
},
......
......@@ -14,8 +14,8 @@
},
"require": {
"doctrine/dbal": "^2.10",
"psr/http-message": "~1.0",
"psr/log": "~1.0.0",
"psr/http-message": "^1.0",
"psr/log": "^1.0",
"typo3/cms-backend": "10.2.*@dev",
"typo3/cms-core": "10.2.*@dev",
"typo3fluid/fluid": "^2.6.6"
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment