Commit 0780cfbd authored by Ioulia Kondratovitch's avatar Ioulia Kondratovitch Committed by Susanne Moog
Browse files

[BUGFIX] Reenable input field for page ID when setting a link via RTE

Remove obsolete dot to make following setting work again:
RTE.default.buttons.link.pageIdSelector.enabled = 1

This now renders an input field for a page ID again when setting
a link via RTE.

Resolves: #88656
Releases: master, 9.5
Change-Id: I25a9cd20fd269f3f4f683ee6474f424897601a86
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/61194


Tested-by: Daniel Goerz's avatarDaniel Goerz <daniel.goerz@posteo.de>
Tested-by: default avatarTYPO3com <noreply@typo3.com>
Tested-by: Susanne Moog's avatarSusanne Moog <look@susi.dev>
Reviewed-by: Daniel Goerz's avatarDaniel Goerz <daniel.goerz@posteo.de>
Reviewed-by: Susanne Moog's avatarSusanne Moog <look@susi.dev>
parent 020f22dc
......@@ -256,7 +256,7 @@ class PageLinkHandler extends AbstractLinkHandler implements LinkHandlerInterfac
public function modifyLinkAttributes(array $fieldDefinitions)
{
$configuration = $this->linkBrowser->getConfiguration();
if (!empty($configuration['pageIdSelector.']['enabled'])) {
if (!empty($configuration['pageIdSelector']['enabled'])) {
$this->linkAttributes[] = 'pageIdSelector';
$fieldDefinitions['pageIdSelector'] = '
<form class="form-horizontal"><div class="form-group form-group-sm">
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment