[TASK] Migrate extension install upgrade wizards to new API