[BUGFIX] Select suitable distribution version in em