[TASK] Update Fluid dependency to 2.4.0+