unify PHP5 check in config_defaults.php and deprecate