[BUGFIX] Fix dependencies for non-composer extensions