[BUGFIX] Ignore "composer/installers" requirement 85/24785/3
authorThomas Maroschik <tmaroschik@dfau.de>
Tue, 15 Oct 2013 08:35:49 +0000 (10:35 +0200)
committerThomas Maroschik <tmaroschik@dfau.de>
Tue, 15 Oct 2013 13:07:16 +0000 (15:07 +0200)
commitdc3bcfc02fc858594cc005fbdfcc490d4ffdeabb
tree49facf154b29c4effe5d5b831ea41451def92b33
parente02418ec3d807d5cd8f6d6d8a7f5123b2b93b400
[BUGFIX] Ignore "composer/installers" requirement

Most extensions that already provide a composer.json file have a
requirement against composer/installers. Our Package Manager tries
to resolve that dependency and files. As the composer/installers
package is not required for an extension to work it is ignored until
the Extensionmanager can handle composer packages natively.

Resolves: #52767
Releases: 6.2
Change-Id: Ia6c57f6006958aadea759cd583f2dce7716be389
Reviewed-on: https://review.typo3.org/24785
Tested-by: Claus Due
Reviewed-by: Sebastian Fischer
Reviewed-by: Fabien Udriot
Tested-by: Fabien Udriot
Reviewed-by: Thomas Maroschik
Tested-by: Thomas Maroschik
typo3/sysext/core/Classes/Package/Package.php
typo3/sysext/core/Classes/Package/PackageFactory.php
typo3/sysext/core/Classes/Package/PackageManager.php