Fixed bug #5789: JS error in new content element wizard with a single item
authorOliver Hader <oliver.hader@typo3.org>
Mon, 2 Jul 2007 16:03:49 +0000 (16:03 +0000)
committerOliver Hader <oliver.hader@typo3.org>
Mon, 2 Jul 2007 16:03:49 +0000 (16:03 +0000)
git-svn-id: https://svn.typo3.org/TYPO3v4/Core/trunk@2374 709f56b5-9817-0410-a4d7-c38de5d9e867

ChangeLog
typo3/sysext/cms/layout/db_new_content_el.php

index 554b947..84eac93 100755 (executable)
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,6 +1,7 @@
 2007-07-02  Oliver Hader  <oh@inpublica.de>
 
        * Fixed bug #4623: Content encoding with x-gzip not possible in IE7
+       * Fixed bug #5789: JS error in new content element wizard with a single item
 
 2007-05-04  Dmitry Dulepov  <dmitry@typo3.org>
 
index e8cb3ba..52475d7 100644 (file)
@@ -279,7 +279,7 @@ class SC_db_new_content_el {
                                        $tL[]='<input type="radio" name="tempB" value="'.htmlspecialchars($k).'" onclick="'.htmlspecialchars($this->doc->thisBlur().$oC).'" />';
 
                                                // Onclick action for icon/title:
-                                       $aOnClick = 'document.editForm.tempB['.$cc.'].checked=1;'.$this->doc->thisBlur().$oC.'return false;';
+                                       $aOnClick = 'document.getElementsByName(\'tempB\')['.$cc.'].checked=1;'.$this->doc->thisBlur().$oC.'return false;';
 
                                                // Icon:
                                        $iInfo = @getimagesize($wInfo['icon']);