[BUGFIX] Add missing fields in functional tests fixtures 61/51661/2
authorTymoteusz Motylewski <t.motylewski@gmail.com>
Mon, 13 Feb 2017 20:26:40 +0000 (21:26 +0100)
committerChristian Kuhn <lolli@schwarzbu.ch>
Tue, 14 Feb 2017 11:35:02 +0000 (12:35 +0100)
Add value to the language_isocode column for sys_language fixture
and CType for tt_content fixture.

Resolves: #79790
Releases: master
Change-Id: I2d83d436c495bc2a8174527f34610880f8a0f9ea
Reviewed-on: https://review.typo3.org/51661
Tested-by: TYPO3com <no-reply@typo3.com>
Reviewed-by: Thomas Hohn <thomas@hohn.dk>
Reviewed-by: Philipp Gampe <philipp.gampe@typo3.org>
Reviewed-by: Thomas Löffler <thomas.loeffler@typo3.org>
Reviewed-by: Wouter Wolters <typo3@wouterwolters.nl>
Reviewed-by: Christian Kuhn <lolli@schwarzbu.ch>
Tested-by: Christian Kuhn <lolli@schwarzbu.ch>
components/testing_framework/Resources/Core/Functional/Fixtures/sys_language.xml
components/testing_framework/Resources/Core/Functional/Fixtures/tt_content.xml

index d28a551..73e6b89 100644 (file)
@@ -8,6 +8,7 @@
         <title>Dansk</title>
         <flag>dk</flag>
         <static_lang_isocode>0</static_lang_isocode>
+        <language_isocode>dk</language_isocode>
     </sys_language>
     <sys_language>
         <uid>2</uid>
@@ -17,5 +18,6 @@
         <title>Deutsch</title>
         <flag>de</flag>
         <static_lang_isocode>0</static_lang_isocode>
+        <language_isocode>de</language_isocode>
     </sys_language>
 </dataset>
\ No newline at end of file
index 49ceb10..59550e4 100644 (file)
@@ -3,6 +3,7 @@
     <tt_content>
         <uid>1</uid>
         <pid>1</pid>
+        <CType>header</CType>
         <header>Test content</header>
         <deleted>0</deleted>
         <t3ver_oid>0</t3ver_oid>