[TASK] Use stable phpunit 4.1 instead of master 79/31179/2
authorChristian Kuhn <lolli@schwarzbu.ch>
Sat, 28 Jun 2014 12:01:42 +0000 (14:01 +0200)
committerChristian Kuhn <lolli@schwarzbu.ch>
Sat, 28 Jun 2014 12:11:34 +0000 (14:11 +0200)
We had to update to phpunit "master" recently due to an issue with
phpunit-mock-objects that was not released yet but fixed in master.
The fix was released with phpunit-mock-objects 2.1.5 today, so we
can switch back to a stable combination of those packages.

Resolves: #59958
Related: #59685
Releases: 6.3, 6.2
Change-Id: I92336adef0291239c7dad606002721c91b2991fa
Reviewed-on: https://review.typo3.org/31179
Reviewed-by: Christian Kuhn
Tested-by: Christian Kuhn
composer.json

index e2426a7..c15196a 100644 (file)
@@ -37,8 +37,7 @@
        },
        "require-dev": {
                "mikey179/vfsStream": "1.3.*@dev",
-               "phpunit/phpunit": "4.*@dev",
-               "phpunit/phpunit-mock-objects": "2.*@dev"
+               "phpunit/phpunit": "~4.1"
        },
        "suggest": {
                "ext-gd": "GDlib/Freetype is required for building images with text (GIFBUILDER) and can also be used to scale images",