[BUGFIX] Enable the RTE with WebKit version 534 on iOS and Android 87/17087/2
authorStanislas Rolland <typo3@sjbr.ca>
Mon, 10 Dec 2012 22:25:03 +0000 (17:25 -0500)
committerStanislas Rolland <typo3@sjbr.ca>
Mon, 10 Dec 2012 22:31:03 +0000 (23:31 +0100)
Since WebKit version 534, contenteditable is supported on iOS and
Android, e.g., iOS 5 and Android 3.

Change-Id: I97da8f7a370ff376b56038aa04101e06dcd7ea83
Releases: 4.5, 4.7, 6.0, 6.1
Resolves: #43603
Reviewed-on: https://review.typo3.org/17087
Reviewed-by: Stanislas Rolland
Tested-by: Stanislas Rolland
typo3/sysext/rtehtmlarea/class.tx_rtehtmlarea_base.php

index e6c1ee8..3e8437c 100644 (file)
@@ -56,7 +56,10 @@ class tx_rtehtmlarea_base extends t3lib_rteapi {
                                ),
                        ),
                        'webkit' => array (
-                               array (
+                               array(
+                                       'version' => 534
+                               ),
+                               array(
                                        'version' => 523,
                                        'system' => array(
                                                'disallowed' => array(