[BUGFIX] Make edit button in FormEngine wizard work again 59/37359/2
authorBenjamin Mack <benni@typo3.org>
Sat, 28 Feb 2015 16:56:53 +0000 (17:56 +0100)
committerChristian Kuhn <lolli@schwarzbu.ch>
Sat, 28 Feb 2015 17:34:14 +0000 (18:34 +0100)
When clicking on the edit button wizard in FormEngine
(e.g. when editing a be_group inside the be_user record)
then there is a JS error preventing from opening a popup.

Resolves: #65415
Relates: #63846
Releases: master
Change-Id: Iafac6759054d0e2ce229b34b17b6a5312e1408df
Reviewed-on: http://review.typo3.org/37359
Reviewed-by: Anja Leichsenring <aleichsenring@ab-softlab.de>
Tested-by: Anja Leichsenring <aleichsenring@ab-softlab.de>
Reviewed-by: Frank N├Ągler <typo3@naegler.net>
Reviewed-by: Wouter Wolters <typo3@wouterwolters.nl>
Reviewed-by: Christian Kuhn <lolli@schwarzbu.ch>
Tested-by: Christian Kuhn <lolli@schwarzbu.ch>
typo3/sysext/backend/Classes/Form/Element/AbstractFormElement.php

index 3625081..95a2283 100644 (file)
@@ -326,8 +326,8 @@ abstract class AbstractFormElement {
                                                $onlyIfSelectedJS =
                                                        'if (!TBE_EDITOR.curSelected(\'' . $itemName . $listFlag . '\')){' .
                                                                'alert(' . GeneralUtility::quoteJSvalue($notSelectedText) . ');' .
-                                                               'return false; .
-                                                       }';
+                                                               'return false;' .
+                                                       '}';
                                        }
                                        $aOnClick =
                                                'this.blur();' .