[TASK] Loosen version constraint for TYPO3 CMS Composer Installers 14/47414/2
authorChristian Opitz <christian.opitz@netresearch.de>
Wed, 30 Mar 2016 07:39:18 +0000 (09:39 +0200)
committerMorton Jonuschat <m.jonuschat@mojocode.de>
Thu, 31 Mar 2016 20:24:06 +0000 (22:24 +0200)
The current version constraint doesn't allow composer to install
bug fix versions of the 1.1 version branch of the composer installers
which is unhandy when there are bug fixes such as for #75273.
The new constraint matches all 1.1.* versions greater 1.1.4

Resolves: #75273
Releases: 6.2
Change-Id: I81ce319ea812d44bcf3dd23602e876eb0f0675d8
Reviewed-on: https://review.typo3.org/47414
Reviewed-by: Mathias Brodala <mbrodala@pagemachine.de>
Reviewed-by: Christian Kuhn <lolli@schwarzbu.ch>
Tested-by: Christian Kuhn <lolli@schwarzbu.ch>
Reviewed-by: Morton Jonuschat <m.jonuschat@mojocode.de>
Tested-by: Morton Jonuschat <m.jonuschat@mojocode.de>
composer.json

index 93f5462..33c5d25 100644 (file)
@@ -36,7 +36,7 @@
                "ext-xml": "*",
                "helhum/class-alias-loader": "1.1.5",
                "doctrine/instantiator": "1.0.5",
-               "typo3/cms-composer-installers": "1.1.4"
+               "typo3/cms-composer-installers": "~1.1.4"
        },
        "require-dev": {
                "mikey179/vfsStream": "1.3.*@dev",