[BUGFIX] Keep phpunit 4.1 branch 15/32115/3
authorChristian Kuhn <lolli@schwarzbu.ch>
Tue, 12 Aug 2014 20:22:08 +0000 (22:22 +0200)
committerChristian Kuhn <lolli@schwarzbu.ch>
Tue, 12 Aug 2014 21:42:24 +0000 (23:42 +0200)
composer.json is configured to fetch latest phpunit 4.x branch.
Since 4.2 was just released stable, it will be used now.

phpunit 4.2 now relies on Ocramius/Instantiator to create mocks
that do not call a constructor during instantiation. This project
was created to cope with a recent security fix in PHP unserialize()
that rendered the old way of creating those mocks invalid.

The instantiator project however has issues with PHP versions
5.3 and 5.6 that lead to some failing tests and need further
investigation.

To not run into this during our next merges, the patch nails
phpunit to 4.1.x for now.

Change-Id: I5feb8346e0713fefe6c8fa899c76d3e040dd1973
Resolves: #60923
Releases: master, 6.2
Reviewed-on: http://review.typo3.org/32115
Reviewed-by: Wouter Wolters <typo3@wouterwolters.nl>
Tested-by: Wouter Wolters <typo3@wouterwolters.nl>
Reviewed-by: Christian Kuhn <lolli@schwarzbu.ch>
Tested-by: Christian Kuhn <lolli@schwarzbu.ch>
composer.json

index c15196a..cefaea5 100644 (file)
@@ -37,7 +37,7 @@
        },
        "require-dev": {
                "mikey179/vfsStream": "1.3.*@dev",
-               "phpunit/phpunit": "~4.1"
+               "phpunit/phpunit": "~4.1.0"
        },
        "suggest": {
                "ext-gd": "GDlib/Freetype is required for building images with text (GIFBUILDER) and can also be used to scale images",