Fixed bug #8851: navFrameScript is not loaded for submodules
authorOliver Hader <oliver.hader@typo3.org>
Wed, 9 Jul 2008 18:55:08 +0000 (18:55 +0000)
committerOliver Hader <oliver.hader@typo3.org>
Wed, 9 Jul 2008 18:55:08 +0000 (18:55 +0000)
git-svn-id: https://svn.typo3.org/TYPO3v4/Core/trunk@3868 709f56b5-9817-0410-a4d7-c38de5d9e867

ChangeLog
typo3/classes/class.modulemenu.php

index a8f3e9d..eb0a9af 100755 (executable)
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,7 @@
+2008-07-09  Oliver Hader  <oliver@typo3.org>
+
+       * Fixed bug #8851: navFrameScript is not loaded for submodules (thanks to Christian Ehret)
+
 2008-07-07  Ernesto Baschny  <ernst@cron-it.de>
 
        * Fixed bug #8703: More Options>Access wasn't being shown in the pages click-menus (Thanks to Andreas Wagner)
index b27b01a..8905ee9 100644 (file)
@@ -287,7 +287,8 @@ class ModuleMenu {
                                                'link'         => $submoduleLink,
                                                'originalLink' => $originalLink,
                                                'prefix'       => $submoduleNavigationFramePrefix,
-                                               'description'  => $submoduleDescription
+                                               'description'  => $submoduleDescription,
+                                               'navigationFrameScript' => $submoduleData['navFrameScript'],
                                        );
 
                                        if($moduleData['navFrameScript']) {