[TASK] Move jquery to npm 66/53066/3
authorJohannes Goslar <jogo@kronberger-spiele.de>
Fri, 2 Jun 2017 22:02:01 +0000 (00:02 +0200)
committerChristian Kuhn <lolli@schwarzbu.ch>
Fri, 2 Jun 2017 22:31:13 +0000 (00:31 +0200)
Resolves: #81446
Change-Id: I10fd5950636d2e4b992e1a03f1720759d9e7c55d
Releases: master, 8.7
Reviewed-on: https://review.typo3.org/53066
Reviewed-by: Markus Sommer <markussom@posteo.de>
Tested-by: Markus Sommer <markussom@posteo.de>
Tested-by: TYPO3com <no-reply@typo3.com>
Reviewed-by: Christian Kuhn <lolli@schwarzbu.ch>
Tested-by: Christian Kuhn <lolli@schwarzbu.ch>
Build/Gruntfile.js
Build/bower.json
Build/package-lock.json
Build/package.json

index d39b434..0265f54 100644 (file)
@@ -453,8 +453,8 @@ module.exports = function (grunt) {
                                        /**
                                         * copy needed parts of jquery
                                         */
-                                       'jquery/jquery-3.2.1.js': 'jquery/dist/jquery.js',
-                                       'jquery/jquery-3.2.1.min.js': 'jquery/dist/jquery.min.js',
+                                       'jquery/jquery-3.2.1.js': '../node_modules/jquery/dist/jquery.js',
+                                       'jquery/jquery-3.2.1.min.js': '../node_modules/jquery/dist/jquery.min.js',
                                        /**
                                         * copy needed parts of jquery-ui
                                         */
index ed4c550..e12e820 100644 (file)
@@ -28,7 +28,6 @@
   },
   "dependencies": {
     "requirejs": "^2.3.2",
-    "jquery": "^3.2.1",
     "jquery-ui": "1.11.4",
     "eonasdan-bootstrap-datetimepicker": "^4.17.45",
     "moment": "^2.17.1",
index dae4661..1082f36 100644 (file)
       "dev": true,
       "optional": true
     },
+    "jquery": {
+      "version": "3.2.1",
+      "resolved": "https://registry.npmjs.org/jquery/-/jquery-3.2.1.tgz",
+      "integrity": "sha1-XE2d5lKvbNCncBVKYxu6ErAVx4c=",
+      "dev": true
+    },
     "js-base64": {
       "version": "2.1.9",
       "resolved": "https://registry.npmjs.org/js-base64/-/js-base64-2.1.9.tgz",
index 01571e3..39868b2 100644 (file)
@@ -31,6 +31,7 @@
     "grunt-ts": "^5.5.1",
     "grunt-tslint": "^3.2.1",
     "jasmine-core": "~2.6.0",
+    "jquery": "^3.2.1",
     "karma": "^1.3.0",
     "karma-chrome-launcher": "^2.0.0",
     "karma-coverage": "^1.0.0",