[BUGFIX] CONTENT cObject slide does not loop 44/40244/2
authorBenjamin Mack <benni@typo3.org>
Mon, 15 Jun 2015 10:47:01 +0000 (12:47 +0200)
committerAndreas Fernandez <typo3@scripting-base.de>
Mon, 15 Jun 2015 10:52:24 +0000 (12:52 +0200)
The CONTENT cObject is looping over the SQL query
when sliding the rootline and/or collecting but never
repeats due to missing braces.

This happened during a cleanup merge in commit
4722b6cf5c97ab415d3d35687ed77750b97e3258.

The patch re-adds the braces.

Resolves: #67034
Related: #54091
Releases: master
Change-Id: Ifc912ea8d5d2861d6888ddc5ac7bd755e3ff6bb4
Reviewed-on: http://review.typo3.org/40244
Reviewed-by: Markus Klein <markus.klein@typo3.org>
Tested-by: Markus Klein <markus.klein@typo3.org>
Reviewed-by: Andreas Fernandez <typo3@scripting-base.de>
Tested-by: Andreas Fernandez <typo3@scripting-base.de>
typo3/sysext/frontend/Classes/ContentObject/ContentContentObject.php

index a68b4cd..4658d8b 100644 (file)
@@ -130,7 +130,7 @@ class ContentContentObject extends AbstractContentObject {
                                }
                                $again = (string)$conf['select.']['pidInList'] !== '';
                        }
-               } while ($again && $slide && (string)$tmpValue === '' && $slideCollectFuzzy || $slideCollect);
+               } while ($again && $slide && ((string)$tmpValue === '' && $slideCollectFuzzy || $slideCollect));
 
                $wrap = isset($conf['wrap.']) ? $this->cObj->stdWrap($conf['wrap'], $conf['wrap.']) : $conf['wrap'];
                if ($wrap) {