Follow-up to bug #7942: "Next" buttons where missing in update wizard.
authorRupert Germann <rupi@gmx.li>
Fri, 19 Nov 2010 15:23:27 +0000 (15:23 +0000)
committerRupert Germann <rupi@gmx.li>
Fri, 19 Nov 2010 15:23:27 +0000 (15:23 +0000)
git-svn-id: https://svn.typo3.org/TYPO3v4/Core/trunk@9491 709f56b5-9817-0410-a4d7-c38de5d9e867

ChangeLog
typo3/sysext/install/mod/class.tx_install.php

index 18be478..cac5055 100755 (executable)
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,7 @@
+2010-11-18  Rupert Germann  <rupi@gmx.li>
+
+       * Follow-up to bug #7942: "Next" buttons where missing in update wizard.
+
 2010-11-18  Stanislas Rolland  <typo3@sjbr.ca>
 
        * Fixed bug #16343: htmlArea RTE: JS-Error when closing "Insert Picture" dialogue
index 7a94e29..a73ee37 100755 (executable)
@@ -6489,12 +6489,12 @@ REMOTE_ADDR was '".t3lib_div::getIndpEnv('REMOTE_ADDR')."' (".t3lib_div::getIndp
                                                                        'identifier' => $identifier,
                                                                        'explanation' => $explanation,
                                                                );
-                                                               
+
                                                                        // only display the message, no button
-                                                               if ($showUpdate == 2) {
+                                                               if ($showUpdate === 2) {
                                                                        $updateMarkers['next'] = '';
                                                                }
-                                                               
+
                                                                $singleUpdate[] = t3lib_parsehtml::substituteMarkerArray(
                                                                        $singleUpdateWizardBoxSubpart,
                                                                        $updateMarkers,