[BUGFIX] sys_action toolbar items doesn't go to right submodule
authorSoren Malling <soren.malling@gmail.com>
Mon, 11 Jun 2012 14:22:51 +0000 (16:22 +0200)
committerBenjamin Mack <benni@typo3.org>
Sat, 23 Jun 2012 07:59:09 +0000 (09:59 +0200)
The toolbar items in the sys_actions toolbar doesn't go to the
right submodule in the "Task center" module - unless the last
chosen submodule was "Tasks".

This patch adds the "mode" setting, so the right submodule is chosen

Change-Id: I0eacf922569005c7eba7cadfd49b15575faa3e60
Resolves: #37906
Releases: 6.0
Reviewed-on: http://review.typo3.org/11931
Reviewed-by: Mattias Nilsson
Tested-by: Mattias Nilsson
Reviewed-by: Wouter Wolters
Tested-by: Wouter Wolters
Reviewed-by: Benjamin Mack
Tested-by: Benjamin Mack
typo3/sysext/sys_action/toolbarmenu/class.tx_sysaction_toolbarmenu.php

index 7db3ee1..0e8f273 100644 (file)
@@ -139,7 +139,7 @@ class tx_sysactionToolbarMenu implements backend_toolbarItem {
                        while ($actionRow = $GLOBALS['TYPO3_DB']->sql_fetch_assoc($queryResource)) {
                                $actions[] = array(
                                        $actionRow['title'],
-                                       'mod.php?M=user_task&SET[function]==sys_action.tx_sysaction_task&show=' . $actionRow['uid'],
+                                       'mod.php?M=user_task&SET[mode]=tasks&SET[function]=sys_action.tx_sysaction_task&show=' . $actionRow['uid'],
                                        t3lib_iconworks::getSpriteIconForRecord(
                                                'sys_action',
                                                $actionRow
@@ -196,4 +196,4 @@ class tx_sysactionToolbarMenu implements backend_toolbarItem {
                return TRUE;
        }
 }
-?>
\ No newline at end of file
+?>