[TASK] Adjust Travis to new requirements for version 7 68/33068/2
authorMarkus Klein <klein.t3@reelworx.at>
Tue, 30 Sep 2014 10:14:02 +0000 (12:14 +0200)
committerWouter Wolters <typo3@wouterwolters.nl>
Thu, 16 Oct 2014 10:40:31 +0000 (12:40 +0200)
Drop the testing for PHP versions below 5.5

Resolves: #61969
Releases: master
Change-Id: I393a463e0ed1648b58c05c1691a65551e4d4bbab
Reviewed-on: http://review.typo3.org/33068
Reviewed-by: Tymoteusz Motylewski <t.motylewski@gmail.com>
Reviewed-by: Christian Kuhn <lolli@schwarzbu.ch>
Tested-by: Christian Kuhn <lolli@schwarzbu.ch>
Reviewed-by: Wouter Wolters <typo3@wouterwolters.nl>
Tested-by: Wouter Wolters <typo3@wouterwolters.nl>
.travis.yml

index 23b3074..3ee0301 100644 (file)
@@ -1,8 +1,6 @@
 language: php
 
 php:
-  - 5.3
-  - 5.4
   - 5.5
   - 5.6
 
@@ -27,10 +25,6 @@ notifications:
     on_failure: always
 
 before_script:
-  - >
-    if [[ "$TRAVIS_PHP_VERSION" = "5.3" || "$TRAVIS_PHP_VERSION" = "5.4" ]]; then
-        pecl install igbinary > /dev/null;
-    fi
   - echo "extension = memcache.so" >> ~/.phpenv/versions/$(phpenv version-name)/etc/php.ini
   - echo "extension = redis.so" >> ~/.phpenv/versions/$(phpenv version-name)/etc/php.ini
   - sudo apt-get install parallel