Fixed issue #17012: [reports] Use javascript goToModule() function in the warning...
authorIngo Renner <ingo.renner@typo3.org>
Thu, 13 Jan 2011 14:29:40 +0000 (14:29 +0000)
committerIngo Renner <ingo.renner@typo3.org>
Thu, 13 Jan 2011 14:29:40 +0000 (14:29 +0000)
git-svn-id: https://svn.typo3.org/TYPO3v4/Core/trunk@10066 709f56b5-9817-0410-a4d7-c38de5d9e867

ChangeLog
typo3/sysext/reports/ChangeLog
typo3/sysext/reports/reports/status/class.tx_reports_reports_status_warningmessagepostprocessor.php

index 9123308..9fd050b 100755 (executable)
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,7 @@
+2011-01-13  Ingo Renner  <ingo@typo3.org>
+
+       * Fixed issue #17012: [reports] Use javascript goToModule() function in the warning message
+
 2011-01-13  Jigal van Hemert  <jigal@xs4all.nl>
 
        * Fixed bug #17006: Language mode is broken as soon as a backend layout is selected for the current page (Thanks to Jo Hasenau)
index 1d6cfc3..4e18968 100644 (file)
@@ -1,3 +1,7 @@
+2011-01-13  Ingo Renner  <ingo@typo3.org>
+
+       * Fixed issue #17012: Use javascript goToModule() function in the warning message
+
 2010-11-14  Ingo Renner  <ingo@typo3.org>
 
        * Changed the overview menu to use the core t3-overview-list CSS class for styling
index a56da93..1b495fc 100644 (file)
@@ -71,7 +71,7 @@ class tx_reports_reports_status_WarningMessagePostProcessor {
 
                                $warningMessages['tx_reports_status_notification'] = sprintf(
                                        $GLOBALS['LANG']->getLL('status_problemNotification'),
-                                       '<a href="mod.php?M=tools_txreportsM1&SET[function]=tx_reports.status">',
+                                       '<a href="javascript:top.goToModule(\'tools_txreportsM1\', 1, \'&SET[function]=tx_reports.status\');">',
                                        '</a>'
                                );
                        }