[TASK] Add absRefPrefix to responsive images 38/25138/5
authorGeorg Ringer <georg.ringer@gmail.com>
Sun, 3 Nov 2013 13:34:35 +0000 (14:34 +0100)
committerSteffen Müller <typo3@t3node.com>
Tue, 30 Dec 2014 19:13:22 +0000 (20:13 +0100)
Responsive images must also use the absRefPrefix
as prefix.

Resolves: #53292
Releases: master, 6.2
Change-Id: I12f4ece9b2dda6fb1f56684aefd4013b4ee907a9
Reviewed-on: http://review.typo3.org/25138
Reviewed-by: Benjamin Mack <benni@typo3.org>
Tested-by: Benjamin Mack <benni@typo3.org>
Reviewed-by: Frederic Gaus <gaus@flagbit.de>
Tested-by: Frederic Gaus <gaus@flagbit.de>
Reviewed-by: Steffen Müller <typo3@t3node.com>
Tested-by: Steffen Müller <typo3@t3node.com>
typo3/sysext/frontend/Classes/ContentObject/ContentObjectRenderer.php

index a5b297c..856321c 100644 (file)
@@ -1508,7 +1508,7 @@ class ContentObjectRenderer {
                                if ($sourceInfo) {
                                        $sourceConfiguration['width'] = $sourceInfo[0];
                                        $sourceConfiguration['height'] = $sourceInfo[1];
-                                       $sourceConfiguration['src'] = htmlspecialchars($sourceInfo[3]);
+                                       $sourceConfiguration['src'] = htmlspecialchars($GLOBALS['TSFE']->absRefPrefix . $sourceInfo[3]);
                                        $sourceConfiguration['selfClosingTagSlash'] = (!empty($GLOBALS['TSFE']->xhtmlDoctype) ? ' /' : '');
 
                                        $oneSourceCollection = $this->substituteMarkerArray($sourceLayout, $sourceConfiguration, '###|###', TRUE, TRUE);