[BUGFIX] Set correct DB configuration in step installer 49/47949/2
authorHelmut Hummel <info@helhum.io>
Thu, 28 Apr 2016 09:42:28 +0000 (11:42 +0200)
committerMorton Jonuschat <m.jonuschat@mojocode.de>
Thu, 28 Apr 2016 09:51:42 +0000 (11:51 +0200)
After the doctrine merge, the configuration for the database name changed.
Reflect this also in the database select step, when the user chooses
to select an empty existing database.

Releases: master
Resolves: #75961
Change-Id: Ie49bf42dd2142736c4d99fe8297b688e833e1a23
Reviewed-on: https://review.typo3.org/47949
Reviewed-by: Nicole Cordes <typo3@cordes.co>
Tested-by: Nicole Cordes <typo3@cordes.co>
Reviewed-by: Morton Jonuschat <m.jonuschat@mojocode.de>
Tested-by: Morton Jonuschat <m.jonuschat@mojocode.de>
typo3/sysext/install/Classes/Controller/Action/Step/DatabaseSelect.php

index f6c12c9..3995d39 100644 (file)
@@ -78,7 +78,7 @@ class DatabaseSelect extends AbstractStepAction
             $existingTables = $this->databaseConnection->admin_get_tables();
             $isInitialInstallation = $configurationManager->getConfigurationValueByPath('SYS/isInitialInstallationInProgress');
             if (!$isInitialInstallation || empty($existingTables)) {
-                $localConfigurationPathValuePairs['DB/database'] = $postValues['existing'];
+                $localConfigurationPathValuePairs['DB/Connections/Default/dbname'] = $postValues['existing'];
             }
             // check if database charset is utf-8
             $defaultDatabaseCharset = $this->getDefaultDatabaseCharset();