[BUGFIX] Localization file not loaded in backend form wizard 07/43307/2
authorAndreas Häfner <andreas.haefner@tritum.de>
Mon, 14 Sep 2015 16:58:20 +0000 (18:58 +0200)
committerOliver Hader <oliver.hader@typo3.org>
Mon, 14 Sep 2015 17:23:59 +0000 (19:23 +0200)
The changes for issue #39280 did not consider that the localization file
for the frontend controller is used in the backend controller as well and
thus, this tiny regression got in, leading to not loading the language
labels anymore in the backend form wizard.

Resolves: #69433
Releases: master
Change-Id: Ia27b5e321f2308cf4c3d3cecdfcb3419b4d4397b
Reviewed-on: http://review.typo3.org/43307
Reviewed-by: Oliver Hader <oliver.hader@typo3.org>
Tested-by: Oliver Hader <oliver.hader@typo3.org>
typo3/sysext/form/Classes/View/Wizard/WizardView.php

index e4ca524..2249128 100644 (file)
@@ -260,7 +260,7 @@ class WizardView extends \TYPO3\CMS\Form\View\Wizard\AbstractWizardView {
         */
        protected function loadLocalization() {
                $wizardLabels = $this->getLanguageService()->includeLLFile('EXT:form/Resources/Private/Language/locallang_wizard.xlf', FALSE, TRUE);
-               $controllerLabels = $this->getLanguageService()->includeLLFile('EXT:form/Resources/Private/Language/locallang_controller.xlf', FALSE, TRUE);
+               $controllerLabels = $this->getLanguageService()->includeLLFile('EXT:form/Resources/Private/Language/locallang.xlf', FALSE, TRUE);
                \TYPO3\CMS\Core\Utility\ArrayUtility::mergeRecursiveWithOverrule($controllerLabels, $wizardLabels);
                $this->getPageRenderer()->addInlineLanguageLabelArray($controllerLabels['default']);
        }