[BUGFIX] Typo in neg_foreign_table in DataPreprocessor 87/42287/3
authorAndreas Wolf <andreas.wolf@typo3.org>
Wed, 5 Aug 2015 18:38:34 +0000 (20:38 +0200)
committerWouter Wolters <typo3@wouterwolters.nl>
Wed, 5 Aug 2015 18:57:59 +0000 (20:57 +0200)
Change-Id: I5f281c99c65a6a3a0d0d527bdd5db02853eb078b
Releases: master, 6.2
Resolves: #68769
Related: #36573
Reviewed-on: http://review.typo3.org/42287
Reviewed-by: Christian Kuhn <lolli@schwarzbu.ch>
Tested-by: Christian Kuhn <lolli@schwarzbu.ch>
Reviewed-by: Wouter Wolters <typo3@wouterwolters.nl>
Tested-by: Wouter Wolters <typo3@wouterwolters.nl>
typo3/sysext/backend/Classes/Form/DataPreprocessor.php

index 35f43de..a8f49b8 100644 (file)
@@ -740,7 +740,7 @@ class DataPreprocessor {
                        $subres = BackendUtility::exec_foreign_table_where_query($fieldConfig, $field, $TSconfig, 'neg_');
                        while ($subrow = $GLOBALS['TYPO3_DB']->sql_fetch_assoc($subres)) {
                                // Resolve move-placeholder, to check the right uid against $dataIds
-                               BackendUtility::workspaceOL($fieldConfig['config']['nes_foreign_table'], $subrow);
+                               BackendUtility::workspaceOL($fieldConfig['config']['neg_foreign_table'], $subrow);
                                $recordList[-$subrow['uid']] = BackendUtility::getRecordTitle($fieldConfig['config']['neg_foreign_table'], $subrow);
                        }
                        $GLOBALS['TYPO3_DB']->sql_free_result($subres);