[BUGFIX] Blank page in Firefox view module 48/24948/5
authorStefan Neufeind <typo3.neufeind@speedpartner.de>
Mon, 11 Nov 2013 22:09:33 +0000 (23:09 +0100)
committerStefan Neufeind <typo3.neufeind@speedpartner.de>
Tue, 12 Nov 2013 14:36:20 +0000 (15:36 +0100)
When you click on the view icon of the view module,
a new page is opened to the website. In Firefox,
if you return to the TYPO3 backend in the view mod,
you got a blank page with a [object Window] text.

Resolves: #52616
Releases: 6.2
Change-Id: If81ecea02550a6ef72f15deeeb40bc74e36ee431
Reviewed-on: https://review.typo3.org/24948
Reviewed-by: Markus Klein
Tested-by: Markus Klein
Reviewed-by: Stefan Neufeind
Tested-by: Stefan Neufeind
typo3/sysext/viewpage/Resources/Private/Layouts/DocHeader.html

index b3f7438..1c8970e 100644 (file)
@@ -26,7 +26,7 @@
                                                Uri was added by javascript window.open and not a simple <a href>
                                                because f:be.buttons.icon does not support the target parameter.
                                        </f:comment>
-                                       <f:be.buttons.icon uri="javascript:window.open('{url}', '');" icon="actions-document-view" />
+                                       <f:be.buttons.icon uri="{url}" additionalAttributes="{onclick: 'window.open(this.href,\'newTYPO3frontendWindow\').focus();return false;'}" icon="actions-document-view" />
                                </div>
                                <div class="right">
                                        <f:be.buttons.icon