# PHP version checking didn't work! Fixed that.
authorRobert Lemke <robert.lemke@typo3.org>
Thu, 9 Sep 2004 08:48:07 +0000 (08:48 +0000)
committerRobert Lemke <robert.lemke@typo3.org>
Thu, 9 Sep 2004 08:48:07 +0000 (08:48 +0000)
git-svn-id: https://svn.typo3.org/TYPO3v4/Core/trunk@455 709f56b5-9817-0410-a4d7-c38de5d9e867

typo3/init.php

index 48ce3de..bf53ef6 100755 (executable)
@@ -196,7 +196,7 @@ if (intval($TYPO3_CONF_VARS['BE']['lockSSL']))      {
 // *******************************
 // Checking environment
 // *******************************
-if (t3lib_div::int_from_ver(phpversion())<4100000)     die ('TYPO3 runs with PHP4.1.0+ only');
+if (t3lib_div::int_from_ver(phpversion())<4001000)     die ('TYPO3 runs with PHP4.1.0+ only');
 if (isset($_POST['GLOBALS']) || isset($_GET['GLOBALS']))       die('You cannot set the GLOBALS-array from outside the script.');
 if (!get_magic_quotes_gpc())   {
        t3lib_div::addSlashesOnArray($_GET);