[BUGFIX] Fix JavaScript error that prevents links to anchor tags in RTE 67/33067/2
authorMichael Schams <typo3@2014.trash.schams.net>
Mon, 29 Sep 2014 09:54:35 +0000 (19:54 +1000)
committerMarkus Klein <klein.t3@reelworx.at>
Tue, 30 Sep 2014 09:57:52 +0000 (11:57 +0200)
This patch fixes invalid JavaScript code (adds a missing closing
bracket), that prevents BE users from creating links to anchor tags
in the RTE.

This is a regression fix to #41413.

Resolves: #61943
Releases: master, 6.2
Change-Id: I8e085e01885333d612cf6776495be259b00a093a
Reviewed-on: http://review.typo3.org/33067
Reviewed-by: Markus Klein <klein.t3@reelworx.at>
Tested-by: Markus Klein <klein.t3@reelworx.at>
typo3/sysext/recordlist/Classes/Browser/ElementBrowser.php

index 7085b9c..68650f1 100644 (file)
@@ -1619,7 +1619,7 @@ class ElementBrowser {
                                                                . '<img' . IconUtility::skinImg($GLOBALS['BACK_PATH'], ('gfx/ol/join'
                                                                        . ($skey + 3 > count($split) ? 'bottom' : '') . '.gif'), 'width="18" height="16"')
                                                                        . ' alt="" />' . '<a href="#" onclick="return link_typo3Page(' . GeneralUtility::quoteJSvalue($expPageId)
-                                                                       . ',' . GeneralUtility::quoteJSvalue('#' . $sval) . ';">' . htmlspecialchars((' <A> ' . $sval))
+                                                                       . ',' . GeneralUtility::quoteJSvalue('#' . $sval) . ');">' . htmlspecialchars((' <A> ' . $sval))
                                                                        . '</a><br />';
                                                }
                                        }