[BUGFIX] Missing/Wrong copy buttons if deflangBinding is disabled 55/22355/3
authorStefan Galinski <stefan.galinski@gmail.com>
Sat, 6 Jul 2013 13:41:16 +0000 (15:41 +0200)
committerGeorg Ringer <georg.ringer@gmail.com>
Tue, 16 Jul 2013 11:47:55 +0000 (13:47 +0200)
Fixes: #49712
Releases: 6.2, 6.1, 6.0
Change-Id: If3aebb786ae6b3f23964704d5f3c13ea7b0fd0af
Reviewed-on: https://review.typo3.org/22355
Reviewed-by: Georg Ringer
Tested-by: Georg Ringer
typo3/sysext/backend/Classes/View/PageLayoutView.php

index 82c33d5..42aab30 100644 (file)
@@ -454,9 +454,7 @@ class PageLayoutView extends \TYPO3\CMS\Recordlist\RecordList\AbstractDatabaseRe
                                                }
                                                if (is_array($row) && (int) $row['t3ver_state'] != 2) {
                                                        $singleElementHTML = '';
-                                                       if (($this->defLangBinding && !$lP) ||
-                                                               (!$this->defLangBinding && $lP && $row['sys_language_uid'] != -1)
-                                                       ) {
+                                                       if (!$lP && ($this->defLangBinding || $row['sys_language_uid'] != -1)) {
                                                                $defLanguageCount[$key][] = $row['uid'];
                                                        }
                                                        $editUidList .= $row['uid'] . ',';