[BUGFIX] EXT:form - subjectField does not work in mail postProcessor 96/43696/2
authorRalf Zimmermann <ralf.zimmermann@tritum.de>
Thu, 1 Oct 2015 14:05:26 +0000 (16:05 +0200)
committerFrans Saris <franssaris@gmail.com>
Fri, 2 Oct 2015 12:46:14 +0000 (14:46 +0200)
Respect the subjectField configuration property in the
mail postProcessor.

Resolves: #70076
Releases: master
Change-Id: I6534f04745d0c88d38beb7ec1a08eb209d0f77be
Reviewed-on: http://review.typo3.org/43696
Reviewed-by: Bjoern Jacob <bjoern.jacob@tritum.de>
Tested-by: Bjoern Jacob <bjoern.jacob@tritum.de>
Reviewed-by: Frans Saris <franssaris@gmail.com>
Tested-by: Frans Saris <franssaris@gmail.com>
typo3/sysext/form/Classes/PostProcess/MailPostProcessor.php

index dfdfe9f..4caa4f5 100644 (file)
@@ -139,8 +139,8 @@ class MailPostProcessor extends AbstractPostProcessor implements PostProcessorIn
        protected function setSubject() {
                if (isset($this->typoScript['subject'])) {
                        $subject = $this->typoScript['subject'];
-               } elseif ($this->getTypoScriptValueFromIncomingData('subject') !== NULL) {
-                       $subject = $this->getTypoScriptValueFromIncomingData('subject');
+               } elseif ($this->getTypoScriptValueFromIncomingData('subjectField') !== NULL) {
+                       $subject = $this->getTypoScriptValueFromIncomingData('subjectField');
                } else {
                        $subject = 'Formmail on ' . GeneralUtility::getIndpEnv('HTTP_HOST');
                }