[TASK] Require "fluid" for "fluid_styled_content" 31/55531/5
authorThomas Löffler <loeffler@spooner-web.de>
Fri, 2 Feb 2018 10:04:56 +0000 (11:04 +0100)
committerBenni Mack <benni@typo3.org>
Sat, 3 Feb 2018 10:13:22 +0000 (11:13 +0100)
When requiring fluid_styled_content in an extension
by composer, the extension fluid should be required and
installed, too.

Releases: master
Resolves: #83756
Change-Id: I1cdd00e842e4b0918db0746ccdf58bb871b8790c
Reviewed-on: https://review.typo3.org/55531
Reviewed-by: Oliver Klee <typo3-coding@oliverklee.de>
Tested-by: TYPO3com <no-reply@typo3.com>
Reviewed-by: Mathias Brodala <mbrodala@pagemachine.de>
Reviewed-by: Reiner Teubner <rteubner@me.com>
Reviewed-by: Mathias Schreiber <mathias.schreiber@typo3.com>
Tested-by: Mathias Schreiber <mathias.schreiber@typo3.com>
Reviewed-by: Benni Mack <benni@typo3.org>
Tested-by: Benni Mack <benni@typo3.org>
typo3/sysext/fluid_styled_content/composer.json
typo3/sysext/fluid_styled_content/ext_emconf.php

index 3913db4..f54c5dd 100644 (file)
@@ -12,6 +12,7 @@
 
        "require": {
                "typo3/cms-core": "9.2.*@dev",
+               "typo3/cms-fluid": "9.2.*@dev",
                "typo3/cms-frontend": "9.2.*@dev"
        },
        "conflict": {
index 05af679..cb299ef 100644 (file)
@@ -10,6 +10,7 @@ $EM_CONF[$_EXTKEY] = [
     'constraints' => [
         'depends' => [
             'typo3' => '9.2.0',
+            'fluid' => '9.2.0',
             'frontend' => '9.2.0',
         ],
         'conflicts' => [],