[BUGFIX] Wrong SQL statements in TCA for sys_category 40/18040/3
authorThomas Löffler <loeffler@spooner-web.de>
Tue, 5 Feb 2013 21:46:01 +0000 (22:46 +0100)
committerChristian Kuhn <lolli@schwarzbu.ch>
Wed, 6 Feb 2013 09:09:37 +0000 (10:09 +0100)
Copy and Paste problem. Table name
'tx_taxonomy_domain_model_concept' instead of
'sys_category'

Resolves: #44911
Releases: 6.0, 6.1
Change-Id: I92130a8dc5416b822edc71be148e35f193b5ea3b
Reviewed-on: https://review.typo3.org/18040
Reviewed-by: Wouter Wolters
Reviewed-by: Thomas Loeffler
Tested-by: Thomas Loeffler
Reviewed-by: Philipp Gampe
Tested-by: Philipp Gampe
Reviewed-by: Christian Kuhn
Tested-by: Christian Kuhn
t3lib/stddb/tca_sys_category.php

index cb06578..5f50637 100644 (file)
@@ -44,8 +44,8 @@ $TCA['sys_category'] = array(
                                'items' => array(
                                        array('', 0)
                                ),
-                               'foreign_table' => 'tx_taxonomy_domain_model_concept',
-                               'foreign_table_where' => 'AND tx_taxonomy_domain_model_concept.uid=###REC_FIELD_l10n_parent### AND tx_taxonomy_domain_model_concept.sys_language_uid IN (-1,0)'
+                               'foreign_table' => 'sys_category',
+                               'foreign_table_where' => 'AND sys_category.uid=###REC_FIELD_l10n_parent### AND sys_category.sys_language_uid IN (-1,0)'
                        )
                ),
                'l10n_diffsource' => array(