[BUGFIX] Error messages are not shown in 123 installation process
authorNicole Cordes <n.cordes@biz-design.biz>
Fri, 21 Sep 2012 10:03:49 +0000 (12:03 +0200)
committerJigal van Hemert <jigal@xs4all.nl>
Fri, 21 Sep 2012 20:12:38 +0000 (22:12 +0200)
Because of a missing ERRORMESSAGES subpart in the 123 install template,
error messages collected while processing are not shown in the frontend.
This patch adds the subpart to the template to show more error information
in the frontend.

Change-Id: I9ee57317958b4505565161c1679d1549c6b89c2c
Fixes: #41158
Releases: 4.5, 4.6, 4.7, 6.0
Reviewed-on: http://review.typo3.org/14813
Reviewed-by: Georg Ringer
Tested-by: Georg Ringer
Reviewed-by: Markus Klein
Tested-by: Markus Klein
Reviewed-by: Jigal van Hemert
Tested-by: Jigal van Hemert
typo3/sysext/install/Resources/Private/Templates/Install_123.html

index 51e7b5d..080aff7 100644 (file)
                                <!-- ###MENU### end -->
                                <!-- ###CONTENT### begin -->
                                <!-- ###CONTENT### end -->
+                               <!-- ###ERRORMESSAGES### begin -->
+                               <br />
+                                       <div class="typo3-message message-error">
+                                               <h4>###LLERRORS###</h4>
+                                               <ul>
+                                                       <!-- ###MESSAGES### begin -->
+                                                               <li>###MESSAGE###</li>
+                                                       <!-- ###MESSAGES### end -->
+                                               </ul>
+                                       </div>
+                               <!-- ###ERRORMESSAGES### end -->
                        </div>
                        <div id="t3-install-box-border-bottom">&nbsp;</div>
                        <div id="t3-install-copyright">