[BUGFIX] Fix PHP warning in shouldFieldBeOverlaid() 23/34523/2
authorMarkus Klein <klein.t3@reelworx.at>
Tue, 18 Nov 2014 20:28:44 +0000 (21:28 +0100)
committerXavier Perseguers <xavier@typo3.org>
Mon, 24 Nov 2014 07:11:06 +0000 (08:11 +0100)
PageRepository::shouldFieldBeOverlaid now properly checks for array-typed
values when mergeIfNotBlank behaviour is requested.

Resolves: #60998
Releases: master, 6.2
Change-Id: I9b536d2261eea6325e0f74365a3a4c85e37b1241
Reviewed-on: http://review.typo3.org/34523
Reviewed-by: Xavier Perseguers <xavier@typo3.org>
Tested-by: Xavier Perseguers <xavier@typo3.org>
typo3/sysext/frontend/Classes/Page/PageRepository.php

index 5ded340..c876d34 100644 (file)
@@ -1413,7 +1413,7 @@ class PageRepository {
                                $checkValue = '';
                        }
 
-                       if (trim($checkValue) === '') {
+                       if ($checkValue === array() || trim($checkValue) === '') {
                                $shouldFieldBeOverlaid = FALSE;
                        }
                }