Fixed a small typo in t3lib_parsehtml_proc
authorMichael Stucki <michael.stucki@typo3.org>
Sun, 4 Feb 2007 21:13:28 +0000 (21:13 +0000)
committerMichael Stucki <michael.stucki@typo3.org>
Sun, 4 Feb 2007 21:13:28 +0000 (21:13 +0000)
git-svn-id: https://svn.typo3.org/TYPO3v4/Core/trunk@1984 709f56b5-9817-0410-a4d7-c38de5d9e867

t3lib/class.t3lib_div.php
t3lib/class.t3lib_parsehtml_proc.php

index 818afbe..8f85f40 100755 (executable)
@@ -2114,9 +2114,8 @@ class t3lib_div {
                                                        if ($options['useCDATA'] && $content != $v) {
                                                                $content = '<![CDATA[' . $v . ']]>';
                                                        }
-                                               }
-                                               elseif (!$options['disableTypeAttrib']) {
-                                                               $attr.=' type="'.$dType.'"';
+                                               } elseif (!$options['disableTypeAttrib']) {
+                                                       $attr.= ' type="'.$dType.'"';
                                                }
                                        }
                                }
index c3663af..95887e2 100755 (executable)
@@ -1497,7 +1497,7 @@ class t3lib_parsehtml_proc extends t3lib_parsehtml {
                } else {
                        $curURL = $this->siteUrl();     // 100502, removed this: 'http://'.t3lib_div::getThisUrl(); Reason: The url returned had typo3/ in the end - should be only the site's url as far as I see...
                        for($a=0;$a<strlen($url);$a++)  {
-                               if ($url[$a]!=$curURL[$a])      {
+                               if ($url{$a}!=$curURL{$a})      {
                                        break;
                                }
                        }