[BUGFIX] Link to install tool in reports leads to old page
authorThomas Löffler <loeffler@spooner-web.de>
Mon, 17 Sep 2012 18:02:09 +0000 (20:02 +0200)
committerChristian Kuhn <lolli@schwarzbu.ch>
Thu, 20 Sep 2012 17:40:12 +0000 (19:40 +0200)
There is a link to install tool on the reports page which leads
to the old page with the missing button "unlock install tool".

Change-Id: If5b33c379581672dbfd2d1024b0dd485e2281b7c
Resolves: #37067
Releases: 6.0, 4.7, 4.6
Reviewed-on: http://review.typo3.org/14671
Reviewed-by: Oliver Hader
Tested-by: Oliver Hader
Reviewed-by: Wouter Wolters
Tested-by: Wouter Wolters
Reviewed-by: Christian Kuhn
Tested-by: Christian Kuhn
typo3/sysext/reports/Classes/Report/Status/SecurityStatus.php

index b264196..7825e33 100644 (file)
@@ -189,7 +189,7 @@ class SecurityStatus implements \TYPO3\CMS\Reports\StatusProviderInterface {
                if ($GLOBALS['TYPO3_CONF_VARS']['BE']['installToolPassword'] == md5('joh316')) {
                        $value = $GLOBALS['LANG']->getLL('status_insecure');
                        $severity = \TYPO3\CMS\Reports\Status::ERROR;
-                       $changeInstallToolPasswordUrl = 'install/index.php?redirect_url=index.php' . urlencode('?TYPO3_INSTALL[type]=about');
+                       $changeInstallToolPasswordUrl = 'mod.php?M=tools_install';
                        $message = sprintf($GLOBALS['LANG']->sL('LLL:EXT:lang/locallang_core.xml:warning.install_password'), '<a href="' . $changeInstallToolPasswordUrl . '">', '</a>');
                }
                return \TYPO3\CMS\Core\Utility\GeneralUtility::makeInstance('TYPO3\\CMS\\Reports\\Status', $GLOBALS['LANG']->getLL('status_installToolPassword'), $value, $message, $severity);