[BUGFIX] Add conflicts with broken sf/finder versions 41/56541/2
authorHelmut Hummel <typo3@helhum.io>
Wed, 4 Apr 2018 10:11:42 +0000 (12:11 +0200)
committerStefan Neufeind <typo3.neufeind@speedpartner.de>
Wed, 4 Apr 2018 12:52:22 +0000 (14:52 +0200)
A regression was introduced in symfony/finder
https://github.com/symfony/symfony/pull/26337

This caused PackageManager to not find any core packages
any more in case they were symlinked.

Composer command (after adding conflict):
composer update --lock

Resolves: #84601
Releases: 7.6, 8.7, master
Change-Id: I914c3b3c4a6c12375ebd9fe5442c3f7ff407de72
Reviewed-on: https://review.typo3.org/56541
Reviewed-by: Mathias Brodala <mbrodala@pagemachine.de>
Tested-by: TYPO3com <no-reply@typo3.com>
Reviewed-by: Nicole Cordes <typo3@cordes.co>
Tested-by: Nicole Cordes <typo3@cordes.co>
Reviewed-by: Georg Ringer <georg.ringer@gmail.com>
Tested-by: Georg Ringer <georg.ringer@gmail.com>
Reviewed-by: Stefan Neufeind <typo3.neufeind@speedpartner.de>
Tested-by: Stefan Neufeind <typo3.neufeind@speedpartner.de>
composer.json
composer.lock
typo3/sysext/core/composer.json

index bb55b82..b4cbbae 100644 (file)
@@ -74,6 +74,9 @@
                "ext-zip": "",
                "ext-mysqli": ""
        },
+       "conflict": {
+               "symfony/finder": "2.7.44 || 2.8.37 || 3.4.7 || 4.0.7"
+       },
        "extra": {
                "typo3/class-alias-loader": {
                        "always-add-alias-loader": true,
index efb4667..bb6a262 100644 (file)
@@ -4,7 +4,7 @@
         "Read more about it at https://getcomposer.org/doc/01-basic-usage.md#composer-lock-the-lock-file",
         "This file is @generated automatically"
     ],
-    "content-hash": "9e7e4b2f0374c71e482a335873a428aa",
+    "content-hash": "cb8d11bbc2ce71a51027d9a85e8859ea",
     "packages": [
         {
             "name": "cogpowered/finediff",
index f8baf8e..3c89843 100644 (file)
@@ -56,7 +56,8 @@
                "ext-mysqli": ""
        },
        "conflict": {
-               "typo3/cms": "*"
+               "typo3/cms": "*",
+               "symfony/finder": "2.7.44 || 2.8.37 || 3.4.7 || 4.0.7"
        },
        "replace": {
                "core": "*"